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Page 10

1

Introduction
This manual describes PRESTO, a USB programmer and
its control software, both manufactured by ASIX.

Chapter 1 gives you ‘quick start’ instructions on how to
start working with the programmer, offers examples of its
connecting to applications and provides technical
specifications.

Chapter 2 focuses on the installation of drivers and
software updates.

Chapter 3 introduces the UP program, which is software
used for controlling all ASIX programmers. You can find
procedures there for setting up the programmer prior to
programming, for actual programming and/or verification
of devices. It also describes how to control the software
from a command line or a DLL library.

Chapter 4 presents the JTAG SVF Player software used for
programming devices with the JTAG interface using .svf/
.xsvf files.

Chapter 5 offers tips and tricks in case of experiencing
difficulties with programming.

Abbreviations & Terms Used
HVP (High Voltage Programming) is a

programming mode in which a higher
voltage than the power-supply voltage is
applied to pin P in the initial phase.

ICSP (In-Circuit Serial Programming). The
meaning of ICSP is identical with the
meaning of ISP (In System Programming) in
this manual, i.e. device programming done
inside a system.

LVP (Low Voltage Programming) is a
programming mode in which none of the
pins has higher than the power-supply
voltage applied.

PDI Program and Debug Interface

SBW (SPY-BI-WIRE) MSP430 microcontroller
interface

TPI Atmel Tiny Programming Interface

VCC If the text features VCC or VDD, they mean
the power-supply voltage on the VDD pin,
which can serve as either input or output
depending on the particular application.

VPP If the text features VPP, it means the
programming voltage on pin P of devices
with High Voltage Programming.

The term “file” means a file with data to be programmed
in context of this manual, in other cases a particular type
of file is specified.
A file with .hex extension means Intel-HEX file whilst a file
with .bin extension means binary file.

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om



Page 11

2

PRESTO
Thank you for buying the PRESTO programmer made by
ASIX s.r.o. It was a wise decision. Feel free to contact our
technical support in case of any questions or doubts.

2.1 Package Content
Your PRESTO package should include:

• PRESTO programmer
• ICSPCAB8 cable
• USB cable (type A - B)
• Info leaflet

2.2 Features
PRESTO is a fast USB In-System programmer suitable for
programming a range of devices such as microcontrollers,
EEPROM or Flash serial memory chips, CPLD, FPGA and
many others.

• USB 1.1 (USB 2.0 compatible) interface, programmer
powered via USB

• 3 MHz in/out
• synchronous programming, JTAG support
• programming voltage from 2.7 V to 5.5 V
• feeds applications with 5 V
• overcurrent protection on VDD and VPP sources
• overvoltage protection on VDD pin

• GO button for quick function selection
• more than one simultaneously running programmer
per PC, command line support, support for Windows
messages and for DLL

• Windows XP or later
• compact

2.3 Quick Start
Please install the drivers and the UP software prior to the
first use of PRESTO.

2.3.1 Windows
Administrator rights are required to run the software
for the first time.

Start with installing the UP program. Its installer installs
the USB driver for PRESTO, too. You can download the
installer from www.asix.tech/prg_up_en.html.

Once the installation is complete, connect the PRESTO
programmer to your computer.
The driver contained in the UP installer is intended for
Windows 7 and later. For older Windows operating system
versions the driver has to be downloaded from
www.asix.net, from download section of the programmer
and unpacked somewhere. After the programmer has
been connected, the operating system asks for the driver.
In "Found New Hardware" dialog the path to the
unpacked driver has to be set.

The green ON-LINE LED should turn on after a few
moments and the Windows Device Manager should
present the programmer as correctly installed.

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

http://www.asix.tech/prg_up_en.html
http://www.asix.net


Page 12

2.4 Use
PRESTO is a fast USB programmer suitable for
programming of a range of devices such as
microcontrollers, EEPROM or Flash serial memory chips,
CPLD, FPGA and many others. It is equipped with
overcurrent protection at the VDD and VPP sources and
with overvoltage protection at the VDD pin.

The programmer is powered via USB. It can feed the
application to be programmed with a voltage of 5 V or it
can utilize an external application’s voltage of 2.7 V to
5.5 V during programming.

The programmer may run under Windows XP or later.

2.4.1 Numerous Supported
Devices

The list of supported devices includes:

• Microchip PIC microcontrollers – devices with serial
programming, which include all PIC and dsPIC devices
with the exception of several obsolete types.

• Atmel AVR microcontrollers – all devices supporting
"SPI Low Voltage Serial Downloading" such as
ATtiny12, AT90S8535 or ATmega128.

• Atmel ATxmega microcontrollers – devices
programmable via JTAG interface such as
ATxmega128A1.

• Atmel AVR32 microcontrollers – AT32UC3A1256, for
example.

• Atmel 8051 microcontrollers – devices that support
ISP programming such as AT89S8253, AT89LP4052,
AT89LP216 or AT89S2051.

• Texas Instruments microcontrollers – 16-bit MSP430,
CC430 (fuse programming is not supported for these
families) and CCxxxx.

• Cypress – PSoC microcontrollers.

• Serial EEPROM and Flash memory chips - I2C
(24LCxx), Microwire (93LCxx) and SPI (25Cxx).

• Devices with JTAG interface, for which an SVF or an
XSVF file can be created. These include CPLD (such as
Xilinx XC95xx and CoolRunner), configuration memory
for FPGA (such as Xilinx XC18Vxx and XCFxxS),
microcontrollers (such as ATmega128) and others.

This, however, is not an exhausting list of possibilities.
Additional types are regularly supplemented in response
to customers’ interest. New software versions are
downloadable from the Internet for free.

2.4.2 USB Connection
PRESTO is controlled and powered through a USB port. It
communicates in the Full-Speed mode and works with a
USB 2.0 port or a USB 1.1 port. This means that
connecting the programmer is fast and easy, requiring
only a single cable.

2.4.3 Programming of
Placed Devices

ISP (In-System Programming) or the special ICSP (In-
Circuit Serial Programming) for the PIC microcontrollers is
currently replacing the traditional method in which
devices were first programmed and only then placed on a
PCB (printed circuit board). Thanks to ISP even SMD
devices with an extremely narrowly spaced pins can
easily be programmed and their firmware upgraded in
already assembled and finished devices.

2.4.4 Programming of
Autonomous Devices

Those who still need to program autonomous devices, i.e.
devices not yet placed on a PCB can use the ISP2ZIF
adapter featuring a ZIF (zero insertion force) socket.
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2.4.5 Programming
Interface

Devices to be programmed are connected through a 8-pin
ISP connector, which is backward compatible with the
ICSP connector for PIC microcontrollers.

2.4.6 Power Supply From
Application

The VDD output can serve as an input using the power
from the application for feeding the output buffers with a
voltage from 2.7 V to 5.5 V or it can become an output
and as such to provide voltage for the application.
PRESTO can power applications with 5 V voltage.

PRESTO detects three levels of external power supply
voltage: 3 V, 5 V and overvoltage.

PRESTO includes an overcurrent protection at pins P and
VDD.

The voltage range can be extend by two optional
adapters (HPR3V3, HPR1V2).

HPR3V3 is an optional accessory for PRESTO by which
PRESTO can power applications with 3.3 V voltage.

HPR1V2 is an optional accessory for PRESTO which
extends input voltage of VDD pin in power from
application mode from 1.2 V to 3.3 V.

2.4.7 User Interface
The programmer status is clearly indicated by two LEDs.
ON-LINE (green LED) informs of connecting to USB while
ACTIVE (yellow LED) signals an activity of the
programming interface.
The GO button significantly increases the operator’s
comfort in repeated programming. It starts programming
or other user-defined commands.

2.4.8 Software
The UP program is a basic software tool for working with
PRESTO, also compatible with the FORTE programmer.

Apart from standard commands, UP provides numerous
above-standard functions, which broaden the
programmer’s applications and simplify its operation.
These include the possibility to define projects, existence
of adjustable parameters when running from the
command line providing for unattended programmer
operation in routine programming, environment
personalization incl. keyboard shortcuts, automatic
generation of serial numbers, etc.

UP has been developed for Windows XP or later.

Modified drivers developed by FTDI are used for
communication through USB.

Devices with the JTAG interface, for which an SVF or an
XSVF file can be created, can be programmed by means
of the JTAG SVF Player software.

The voltage at the VDD pin is permanently displayed in
UP for greater comfort and for monitoring of the
operation. The reset signal is conveniently controlled by a
single button.

2.4.9 Debugging
PRESTO provides user with support for debugging ARM
microcontrollers through OpenOCD which is an open
source debugging system originally developed by
Dominic Rath. OpenOCD uses GDB for access to debug
functions. User can communicate with OpenOCD via a
command line and telnet.

The revision 717 of OpenOCD, which can be found on our
website in a program package together with the ARMINE
program, is supported officially.
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2.5 Controls and
Connectors

Fig. 2: The PRESTO programmer

PRESTO features two LEDs, a button, a connector for
linking to USB and a programming connector.

2.5.1 Programming
Connector

The programming connector is a 8 way single row plug
with pin No. 2 (in standard numbering) missing. Spacing
between pins is 2.54 mm.

Fig. 3: Programming connector

Pin Name Type Description
P1 VPP I/O,VPP signal input/output orVPPoutput
P2 key
P3 VDD PWR power input/output
P4 GND PWR signalgrounding
P5 DATA/

MOSI
I/O signal input/output

P6 CLOCK O signaloutput
P7 MISO I signal input
P8 LVP I/O signal input/output

Table 1: programming connector

2.5.2 GO Button
his button simplifies work with the application being
programmed. It triggers device programming or another
pre-programmed function. For further information on
settings see Setting the GO Button
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2.5.3 LED Indicators
ON-LINE
The green LED informs you that PRESTO is connected to a
computer and that the computer and the programmer
“understand each other”, i.e. drivers are installed and
work correctly.

ACTIVE
The yellow LED informs you that there is ongoing
communication between the programmer and a device.

2.5.4 USB Connector
A standard USB (type B) connector is provided for
connecting to a computer. The programmer uses the
USB Full-Speed interface for communication.

2.6 Connecting to
Application
The programmer should be connected to an application to
be programmed with an ICSPCAB8 which is designed for
2.54 mm spacing.

Fig. 4: ICSPCAB8

The connectors are specified in the next chapter.

2.6.1 Custom-made
Connecting Cable

Should an application to be programmed have a non-
compatible type of connector for linking to the
programmer, the customer can make his/her own
programming cable. Its length should not exceed 15 cm.
The following table lists markings of connectors by FCI
Electronics suitable for making a custom cable. Of course,
it is possible to use any similar ones:
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FCImarking Description
65039-036LF housing, 1pin
65039-029LF housing, 1x 8 pins
47217-000LF pin

Table 2: ICSP cable - material list

A cable with a cross-section between 0.1 and 0.3 mm2

may be used for making the custom connecting cable.

2.6.2 Programming in ZIF
Socket

If programming of autonomous device is required, i.e.
those that are only later connected to an application, it is
possible by means of our optional ISP2ZIF accessory.

Fig. 5: ISP2ZIF

ISP2ZIF consists of a zero insertion force (=ZIF) socket
and an ICSP connector for connecting to the programmer,

which can also provide voltage for feeding the program
circuitry.

2.6.3 Connecting
Procedure

The correct procedure for connecting the programmer:
first connect PRESTO to the target application, then
connect PRESTO to the USB and finally turn on the
application’s power supply.

Please make sure that the GND of the application, the
programmer and the USB are interconnected before
signals and the power are applied.

Important warning
If anapplication is poweredby a switched
powersourceor isnot grounded,a significant
voltage differencemay appearbetweenthe
programmer’s groundandtheapplication’s
ground.This coulddamagethe programmer.

The simplest way of connecting the GND prior to the
other signals is to ground the application before
connecting it to the programmer. This can, for example,
be achieved by making the GND pin of the application’s
ICSP connector longer than the other pins. It will make
sure that both grounds are interconnected first.
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Pin AVR AVRTPI 8051 JTAG

P1 RESET RESET RESET USR
P2

P3 VCC VCC VCC VDD
P4 GND GND GND GND
P5 MOSI TPIDATA MOSI TDI
P6 SCK TPICLK SCK TCK
P7 MISO MISO TDO
P8 SS TMS

Table 3: Connection list No.1

Pin PIC MSP430 MSP430
SBW

TI CCxxxx

P1 MCLR TEST RESET
P2

P3 VDD VCC VCC VDD
P4 VSS VSS VSS GND
P5 PGD TDI SWBTDIO Debugdata
P6 PGC TCK SWBTCK Debugclock
P7 TDO
P8 LVP TMS

Table 4: Connection list No.2

Pin PSoC I2C SPI Microwire

P1 XRST CS CS
P2

P3 VDD VDD VDD VDD
P4 VSS GND GND GND
P5 ISSP-data SDA SI DI
P6 ISSP-SCLK SCL SCK CLK
P7 SO DO
P8 ORG(PRE)

Table 5: Connection list No.3

2.6.4 Connection Examples
The following text presents examples of connections
between PRESTO and the device being programmed. We
use a notation according to the manufacturer datasheet
of each particular device.

PIC Microcontrollers

Fig. 6: PIC microcontroller

1) Not all PIC microcontrollers have the PGM pin. The
PGM pin can be connected to programmer’s L pin, to
VSS via a pull-down resistor (for HVP programming)
or to VDD via a pull-up resistor (for LVP
programming).
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2) The whole device must be erased before
programming if code/main memory protection (CP) or
data memory protection (CPD) is active.

3) Some PIC devices cannot be erased with CP or CPD
active being powered by voltage less than 5 V.

4) If a microcontroller has more than one power-supply
VDD or VSS pin, all of them must be connected
including the AVDD and AVSS pins.

5) PIC microcontrollers which require 3 V or lower power
supply must be fed from external power supply
because PRESTO can only provide 5 V voltage.

6) Some PIC microcontrollers require voltage less than
13 V on the MCLR pin while the programmer can only
set 13 V voltage level on VPP. If such device has been
selected in UP, a warning message is displayed. It is
recommended to limit voltage on the MCLR pin by an
external circuit (a potential divider or a Zener diode
and a resistor).

VPP Resistor
9V 390Ω
11V 200Ω

Table 6: Recommended resistors values with Zener diode (the
value also depends on the rest circuit)

7) If the LVP mode is used, it is recommended to check
whether the LVP fuse is still set after erasing the part.

8) Programming of PIC32 devices is supported by
means of the ICSP interface only with external 3 V
power supply.

9) Devices with an ICPORT fuse must have the
dedicated ICSP port off for LVP programming.

10) PIC24 and dsPIC33 devices may be programmed
using PE (Programming Executive) or using the
standard method. Programming by means of PE is
usually faster.

11) Programming of some new PIC microcontrollers in the
HVP mode can cause that a warning message
indicating overcurrent on VPP appears. If that
message does not indicate a real fault it could be
caused by different technology which has been used
by Microchip for producing new devices, although
they are from pristine families. These devices have
slightly different parameters. It could be solved by
connecting capacitor of 1 nF between the VPP pin
and GND and resistor of 10 Ω in serial with VPP signal
if the fault persists.

12) When the MCU debug mode is enabled using a fuse,
the programmer cannot communicate with it.

AVR Microcontrollers

Fig. 7: AVR microcontroller

1) A source of the clock signal, which is set in the device
or which will be set by fuses during programming
must be connected to the device. A crystal must be
connected if set up as the clock source.

2) Device fuses have been set up by the producer to the
internal oscillator with a frequency of 1 MHz. In the
initial programming, the device should be
programmed with “Oscillator frequency” set up at
“>750 kHz” or lower in the “PRESTO programmer
settings” window.

3) Not all AVR microcontrollers allow use of a crystal
(e.g. ATtiny13, ATtiny15).
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4) After the device fuses are correctly set up, right-click
(i.e. using the right mouse button) inside the
Configuration window and choose Learn fuses .
This saves the fuses in the up.ini file or in the project
if used. This is necessary due to the fact that .hex
files for AVR microcontrollers themselves do not
contain configuration fuses. If a device is
programmed from the command line, a .ppr project
file containing saved fuses needs to be used.

5) Ticking the Open file with data memory
automatically option in the File menu loads data
for the data memory simultaneously with the code/
main memory data.

6) Use the EESAVE fuse if preservation of data memory
is required. If the EESAVE is active, choose Program
all except data memory for programming,
otherwise a warning appears at this place (blank
check of data memory).

7) HPR3V3 is an optional accessory for programming
AVR microcontrollers which reguire 3.3 V voltage with
PRESTO internal 5 V power supply.

8) HPRAVR is an optional accessory for programming
AVR microcontrollers in applications with the
ISP10PIN standard connector on the device's side.

9) Some AVR devices have their ISP interface provided
at different pins than the SPI interface. Further
information can be found in the device data sheet (in
the Serial Downloading section).

AVR with TPI Interface (e.g.
ATtiny10)

Fig. 8: AVR microcontroller, TPI interface

1) These microcontrollers require voltage 12 V on the
RESET pin during programming in the HVP mode
while the programmer can only set 13 V voltage level
on VPP. Therefore it is necessary to limit voltage on
the RESET pin by an external circuit. There is no need
of any external circuit for the LVP mode which is
preferred.

Atmel 8051

Fig. 9: Atmel 8051 microcontroller
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1) The SS pin must be connected only for AT89LP2052 /
4052 / 213 / 214 / 216 / 428 / 828 / 6440 / 51RD2 /
51ED2 / 51ID2 / 51RB2 / 51RC2 / 51IC2.

2) AT89LP213, AT89LP214 and AT89LP216 have the
inverse reset logic. Thus an appropriate resistor must
be pulled-up to VCC.

3) PRESTO can not program devices containing the
letter “C” in their name, however, it supports devices
with “S” in their name, of which some are compatible
with the “C” types. For example, AT89C2051 is not
supported, but AT89S2051 is.

4) The software assumes that while programming
AT89LP52, the device’s POL pin is in logical 1. If POL
is in logical 0, the Inverse RESET option should be
activated in the program. For AT89LP51RD2,
AT89LP51ED2, AT89LP51ID2, AT89LP51RB2,
AT89LP51RC2 and AT89 LP51 IC2 the software
assumes the POL pin in logical 0.

Cypress PSoC

Fig. 10: Cypress PsoC microcontroller

1) The way of entering in the programming mode
should be set in the PRESTO programmer settings
window. Devices without an XRST pin can only use
initialization through the power-on reset (by power
supply). Devices with an XRST pin may use both
methods, but the method using the reset signal for
initialization is better as it can be used in
combination with an external power supply.

2) Algorithm programming in the PRESTO
programmer settings window should be set in
accordance with the power supply cable used.

MSP430 with TEST pin without
SBW interface

Fig. 11: MSP430 microcontroller, TEST pin, without SBW

1) Not all MSP430 microcontrollers have the TEST pin.
2) This interconnection can be used with e.g.

MSP430F1xx, MSP430F4xx, MSP430F21x1, but not
with MSP430F20xx or MSP430F22xx.

3) If the oscillator calibration values are saved in the
information memory and this memory is not going to
be re-programmed (erased) during programming, the
device should be programmed with the Cal Int. RC
(=calibrated internal RC oscillator) option selected in
the PRESTO programmer settings window. In the
other cases Not Cal Int. RC (=not calibrated internal
RC oscillator) should be selected.
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4) The safety fuse on the JTAG interface cannot be
blown by the PRESTO programmer.

5) The HPR3V3 adapter should be used for feeding
these microcontrollers (without the SBW interface)
from PRESTO internal 5 V power supply.

MSP430 / CC430 with SBW
interface

Fig. 12: MSP430 / CC430 microcontroller, SBW

1) Microcontrollers with SBW interface could be
programmed only through this interface. It concerns
e.g. MSP430F20xx, MSP430F22xx or MSP430F5xxx.

2) If the oscillator calibration values are saved in the
information memory and this memory is not going to
be re-programmed (erased) during the programming
process, the device should be programmed with the
Cal Int. RC (=calibrated internal RC oscillator)
option selected in the PRESTO programmer
settings window. In the other cases Not Cal Int. RC
(=not calibrated internal RC oscillator) should be
selected. There is no need to select the oscillator for
the MSP430F5xxx and CC430 devices.

3) The safety fuse on the JTAG interface cannot be
blown by the PRESTO programmer.

4) Speed in the PRESTO programmer sett ings
window should be slow down if any external
capacitor is connected to the device's reset pin.

5) The PRESTO programmer also erases the Segment A
of the information memory with the
Erase Segment A option selected.

TI (Chipcon) CCxxxx
<<( ti_chipcon.jpg | 10cm | TI (Chipcon) Ccxxxx
microcontroller )

I2C Memory Chips

Fig. 13: I2C memory chips

1) The programmer uses an internal 2.2 kΩ pull-up
resistor on the data wire (SDA) when working with an
I2C device.

2) If the device to be programmed is 24LC(S)21A or
24LC(S)22A, its VCLK pin must be connected to VDD
during programming.

3) 34xx02 memory chips need “high” voltage at the A0
pin for commands protecting it against SWP and
CSWP recording. The “high” voltage is generated at
pin P, which must be connected to pin A0 in this
case. The memory chip pins A0, A1 and A2 must be
connected manually according to the selected
protection mode.
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SPI Memory Chips

Fig. 14: SPI memory chips

1) Some devices have WP, HOLD or RESET pins. All of
them must be connected to the required logic level in
such a way as not to block the communication or
device programming.

2) Different manufacturers mark the memory chips' SPI
pins with different names. Some of them are listed in
the following table:

Nameonfigure Atmel, SST ST
DI SI D
DO SO Q
CLK SCK C
#CS CS, CE S

3) The HPR3V3 adapter should be used for feeding SPI
memory chips from PRESTO internal 5 V power
supply.

Microwire Memory Chips

Fig. 15: Microwire memory chips

1) Pin L determines the memory organization as either
8-bits or 16-bits per word. The user selects the
required organization in the UP program and PRESTO
then sets this pin to the corresponding logic level. If
this memory pin is firmly connected to the correct
logic level inside the application, pin L in the
programmer remains disconnected.

2) If used in combination with the M93Sx6 memory chip,
the programmer's L pin must be connected to the
device's PRE pin to serve for selecting the protection
register.

JTAG Interface

Fig. 16: Components with JTAG interface
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1) Pin P is configurable in the JTAG Player utility. It can
be set to keep the device in reset during
programming. This is needed for Atmega devices, for
example.

2) The programmer always uses an external
power-supply vo ltage for SVF or XSVF fi le
programming by means of the JTAG Player
util ity.

3) ARM microcontrollers can be programmed and
debugged through JTAG interface. The ARMINE
program, which can be found on our website, serves
ARM microcontrollers programming. For more
information on ARM microcontrollers programming
see the ARMINE program help.

4) PRESTO provides user with support for debugging
ARM microcontrollers through OpenOCD which is an
open source debugging system originally developed
by Dominic Rath. OpenOCD uses GDB for access to
debug functions. User can communicate with
OpenOCD via a command line and telnet.

5) The revision 717 of OpenOCD, which can be found on
our website in a program package together with the
ARMINE program, is supported officially.

6) The HPR1V2 adapter should be used if power supply
voltage lower than 2.7 V

7) AVR32 microcontrollers are to be programmed from
the UP software through the JTAG interface. The
device must not be reset during programming.

8) ATxmega microcontrollers with the JTAG interface
can be programmed from the UP software through
this interface. Pin P is not needed for programming.
The HPR3V3 adapter should be used for feeding
these devices from PRESTO internal 5 V power
supply.

2.7 Built-in Protection
The PRESTO programmer provides internal overcurrent
protection on the VPP and VDD pins and overvoltage
protection on the VDD pin.

PRESTO is able to detect overcurrent on the VPP or VDD
pin and consequently to disable these pins but only when
PRESTO is connected to a PC and the UP program has
been launched. If overvoltage on VDD pin is detected a
warning message is displayed.

All I/Os have their 27 Ω resistors for better shortage
endurance. Inputs, where it is technically possible, are
equipped with Zener diodes for better overvoltage
endurance.

Any voltage peak higher than 7.5 V or any current higher
than 20 mA on any I/O can cause damage of the
programmer.

Important warning
PRESTOmust be connected toa PC and the
UPprogram must be launchedforcorrect
functionof internalprotection.
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2.8 Technical Specifications
2.8.1 Limit Values
Operating
temperature

min.0 °C max. +55 °C

Storagetemperature min.-40 °C max. +85 °C
Maximumcurrent on
USB

max.370 mA

Voltage at any pin1 min.-0.5V max.6.5V
Maximumcurrent on
I/Opin

20 mA

ESDprotection(HBM
model)

±4 kV contact
±8 kV air

Table 7: Limit values

2.8.2 Operating
Specifications
Important Warning
Failureto respect these parametersmay
damagethe programmerorthe connected
computer.

VDDfeedingvoltage supplied by
programmer

5V

VDDfeedingvoltage supplied by
application

2.7V to 5.5V

Maximumcurrent drawnfrom
VDD

100mA

Maximumcurrent drawnfrom
VPP

50 mA

Maximumcurrent drawnfrom I/
O pin

4 mA

Allowed input voltageonpins 0to 5.5V
Ppin output voltage 13V or logic levels
VILinput voltage max.0.5V
VIH input voltage min.2.0V
VOLoutput voltage max.0.44 V @VDD=4.5V

typ. 0.1V
VOHoutput voltage min.3.8V @VDD=4.5V

typ.VDD- 0.1V
Resistanceto short circuiting limited2
Operating system Windows3 32/ 64-bit
USBcompatibility USB 1.1 Full Speed

USB 2.0 compatible
USB connector type B
Dimensions 112x 64x 22mm
Weight 80g
Grossweight 180g

Table 8: Operating specifications

1 Pin VPP configured as an output has a voltage +13 V
2 For more information see Built-in Protection
3 Windows XP, Windows Vista, Windows 7, Windows 8,
Windows 8.1, Windows 10, Windows 11
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2.8.3 Declaration of
Conformity and RoHS

Declaration of Conformity and RoHS directive documents
are available at www.asix.tech in the Documents section.
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3

DRIVERS
This chapter deals with driver installation and updates.

3.1 Driver Installation
3.1.1 Windows Operating

Systems
The user must have administrator rights to install and run
the UP program for the first time. Standard user rights are
sufficient for further use.

PRESTO drivers are installed automatically as part of the
UP program installation.

Windows 7 and later
Start with installing the UP program. Its installer installs
the USB driver for PRESTO, too. You can download the
installer from www.asix.tech/prg_up_en.html.

Once the installation is complete, connect the PRESTO
programmer to your computer. The green ON-LINE LED
should turn on after a few moments and the Windows
Device Manager should present the programmer as
correctly installed.

Older supported Windows
versions
The driver contained in the UP installer is intended for
Windows 7 and later. For older Windows operating system
versions the driver has to be downloaded from
www.asix.net, from download section of the programmer
and unpacked somewhere. After the programmer has
been connected, the operating system asks for the driver.
In "Found New Hardware" dialog the path to the
unpacked driver has to be set.
During the installation, the operating system will ask
whether it should install the software, which has not
passed the Microsoft compatibility test for Windows. Click
Continue Anyway .

Fig. 17: Compatibility test dialog window

The green ON-LINE LED should turn on after a few
moments and the Windows Device Manager should
present the programmer as correctly installed.
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3.2 Driver Updating
PRESTO communicates with the PC through a USB circuit
produced by FTDI www.ftdichip.com, which also develops
drivers for these circuits.

The latest drivers are always included in the UP
installation pack.

Drivers for the Windows operating system have been
stable for a long time and therefore no further updates
are usually needed, unless additional applications using
the FTDI circuits on the given PC so require.

However, should you need to update your driver, the
simplest way of doing so is to update the UP program.

Download the latest UP installer from the web and install
the new version without risk of losing your personalized
program setup data or data of your projects. The new
version will replace the original one.
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4

Usage under Linux
The support of ASIX products in Linux was
discont inued.

Las t vers ion where we tes ted our products was
UBUNTU 20.04 .2 LTS and Wine 5.0 .

Our customers informed us that our products could
be successful ly used up to Wine 6.0, but not in
higher vers ions.

The software for the programmers is capable of working
under Wine. For USB access it uses libftd2xx.

Step 1: Install libftd2xx and libftchipid
Install 32-bit versions of libftd2xx and libftchipid by FTDI,
even if you use 64-bit kernel. The application is a 32-bit
binary and requires 32-bit libraries.

The driver can be found on FTDI web at "Drivers/D2XX
Drivers" section.
• Extract libftd2xx.so.1 .1 .0 ( in case of newer version
replace 1.1.0 with the latest version) and libftchipid
and copy the files libftd2xx.1 .1 .0 .so and
libftchipid0 .1 .0 into the directory for 32-bit
libraries (typically /usr/lib/i386-linux-gnu/ ).

• ln -s libftd2xx.so.1 .1 .0 /usr/lib/i386-linux-
gnu/libftd2xx.so.1 (it is typically sufficient to run
ldconfig to achieve this)

• ln -s libftd2xx.so.1 .1 .0 /usr/lib/i386-linux-

gnu/libftd2xx.so.0 (must be made manually)
• ln -s libftchipid.so.0 .1 .0 /usr/lib/i386-

linux-gnu/libftchipid.so.0 (it is typically sufficient
to run ldconfig to achieve this)

• The library searches for device files in /dev/bus/usb.
Please ensure that /dev/bus/usb directory contains
special files to access USB devices.

• Check that your device is recognized by the system
(use command lsusb).

• Check your access rights to the corresponding files in /
dev/bus/usb (command ls -la /dev/bus/usb/ ) .
Probably you will not have as a user the r+w access
rights for these files.

• If you have not access rights and you are using udev:

Add a new file with udev rules to the directory /etc/
udev/rules .d or /lib/udev/rules .d (Depending on
your distribution). Suitable name for this new file is 51-
asix_tools.rules. Insert the following lines to this file :
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0403",
ATTRS{idProduct}=="f1a0", MODE:="0666", SYMLINK
+="asix_presto"
SUBSYSTEMS=="usb", ATTRS{idVendor}=="a600",
ATTRS{idProduct}=="a000", MODE:="0666", SYMLINK
+="asix_sigma"
SUBSYSTEMS=="usb", ATTRS{idVendor}=="a600",
ATTRS{idProduct}=="a003", MODE:="0666", SYMLINK
+="asix_forte"
SUBSYSTEMS=="usb", ATTRS{idVendor}=="a600",
ATTRS{idProduct}=="a004", MODE:="0666", SYMLINK
+="asix_omega"
VID and PID values can be determined using the listing of
connected devices by the lsusb command.

Step 2: Install wine
It is necessary to install 32-bit version of wine (for
example wine-1.4:i386).

The Wine versions over 6.0 are not supported.

Step 3: Install lin_ftd2xx
The lin_ftd2xx is available at ASIX web.
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Check environment variable WINEDLLPATH. It should
point to directory where are 32-bit wine DLLs, typically /
usr/lib/i386-linux-gnu/wine. Install lin_ftd2xx by ASIX
into this directory.

Installation of the Microsoftm TrueType core fonts are
recommended. These fonts may be obtained by installing
msttcorefonts package from Ubuntu package repository.

Note:
Library libftd2xx requires also access rights during
opening of the programmer or logic analyzer to all FTDI
serial devices to check that this is not the device it wants
to open.
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5

UP SOFTWARE
UP is a name for control software designed for
programmers made by ASIX. The program offers many
advanced functions and enables an operator to control
the programming process either from the software
interface or remotely from the command line utilizing
Windows messages and the DLL library. The program runs
under Windows.

5.1 Abbreviations Used
Menu→ item bold italicsfollowed by the arrow sign→ make

referencesto particular items inmenus, namesof
tabs(cards) ina particularwindow.

5.2 Installation
Installation is very easy. The installation program can be
downloaded from www.asix.tech/prg_up_en.html. Run the
installer (UP_xxx_EN.EXE, where xxx represents the
version number). There is no need to close other running
applications. The installation process takes only a few
seconds and requires you to press the Enter key a few
times. No modifications to the operating system take
place during installation, i.e. no computer restart is
needed and the program can be used immediately after
completion (by clicking its icon, for example). After the
first start, the program asks which language it should use
(English or Czech), which programmer to work with (e.g.
FORTE) and which port the programmer is connected to.

If needed, the program can be uninstalled using the Add/
Remove Programs icon in the Control Panel or manually
by deleting the corresponding directory and desktop

shortcut(s).

A previous program version (if it exists) does not have to
be removed before installing a newer version. Use of the
latest available version is recommended.

5.3 Device Programming
The following sections describe the ways of programming
devices and things to pay special attention to.

5.3.1 Programmer
Selection

Before a device can be programmed, the programmer
which will be used needs to be selected. Currently either
FORTE or PRESTO can be chosen.

Select the programmer by going to Options → Select
programmer or by double-clicking the programmer
name displayed in the top right corner of the program
window. The following dialog window opens:

Fig. 18: Programmer selection

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

http://www.asix.tech/prg_up_en.html


Page 31

If the programmer is connected to a computer and no
other program communicates with it, its serial number
gets displayed. You can test communication with the
selected programmer by pressing the Test... button.

If the Always use this S/N choice is set, the currently
selected programmer is used even when in a loaded
project file there is defined a different programmer serial
number. Serial number defined on the CommandLine has
priority before this choice.

5.3.2 Projects
It is recommended to use projects for device programing
in UP.

Projects save all settings directly associated with
particular device programming such as device type,
required voltage, verification method, name of file
containing the programming data and many other
important pieces of information.

A new project can be created by choosing File → New
project.

This is followed by selecting a device type, a file with
programming data, settings of the device's configuration
word, applied voltage and other important parameters.

configuration word, applied voltage and other important
parameters.

Once all required selections are made, save the project by
choosing File → Save project.. .

An existing project can be opened by choosing File →
Open project....

5.3.3 Device Type
Selection

Select the device type by choosing Device → Select
device or by double-clicking the device name displayed
in the top right corner of the program window.

Fig. 19: Device selection

A filter is available for sorting devices by families and
another one for Quick search. Just start typing an
important part of the device's name in its field. This
radically reduces the list of devices and speeds up the
whole selection process.

The Quick search filter allows use of the question mark as
a wild-card for a part of the name, for example
PIC18?20 .

There is also a list of 10 Recently used devices where it
is possible to select one.

5.3.4 Program settings
It is advisable to fine-tune the program behavior by
adjusting the settings to suit your particular needs. This
can be done by choosing Options → Program settings.

There is a great number of possible settings. If you are
not sure that all the settings are correct, use the Load
defaults button, which returns all the setting to the
original (default) state.

If you are updating UP to a new version, all the existing
settings will be preserved.

A detailed description of all settings can be found in
Menus, so we will pay attention to only a few important
settings for now.
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Delay for VDD switching on/off
when supplied from
programmer
If you supply power to your application from the
programmer during programming and UP announces
overcurrent on VDD pin due to charging capacitors in the
application, it may be advisable to enlarge the switch on
time in Program sett ings. . . → Programming → Delay
for VDD switching on/of f when suppl ied from
programmer . This might be necessary to give the
programmer enough time to charge the large capacitors
in the application.

At the same place it si possible to set the discharge time,
when the program announces, that the VDD was not fully
discharged.

Fig. 20: Programming settings
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Production Programming
Settings
If you want to perfectly verify your production to make
sure that the device is correctly programmed, you can
use the Program sett ings → Programming → Veri fy
with two supply voltages option and to apply the
lowest and the highest voltage allowed for the device as
the limits. Some manufacturers recommend this option
for the production programming. However, it is only
available if the application is supplied with power from
FORTE.

Program sett ings → Panels → Show mass production
counter in status bar could be a useful tool visibly
monitoring numbers of successfully and unsuccessfully
programmed devices. The counter can be reset in Device
→ Program → Mass production → Counter reset .

Program sett ings → Seria l numbers → Log to fi le can
be used as another convenient assistant. With this option
selected, information on the programming progress of
individual devices gets recorded (logged) in a selected
file.

If you wish to automatically include the serial number
during production programming, you have a great range
of possibilities concerning what the number should look
like and where it should be positioned in the memory. All
serial number settings can be found on the Serial
numbers tab.

For further information on serial numbers see Serial
Numbers.

Settings for Programming
During Development
If you are frequently changing the content of the
programming data such as during application
development, for example, you can simplify your work by
using the GO button, which typically serves for

programming and verification of the whole memory
content. The function of this button is programmable and
can be set up under the Options → Key shortcuts menu
in the GO button section.

The use of the GO button for programming should be
accompanied by Options → Program settings →
Programming → Reload fi le before every
programming option.

Options → Program sett ings → Programming → Keep
manually modified data causes that manually modified
data are not rewritten using the automatical file reload
before programming.

Options → Program sett ings → Programming → Warn
before fi le load, when data in some editor have
been changed causes that a warning appears if data
have been changed in any editors and automatic file
reloading option is set.

Options → Program settings → Programming →
Warn, when the loaded fi le has not changed causes
that a warning appears if the file loaded before
programming has not changed.

The following option can also be useful: Program
sett ings → Programming → After programming:
Close status window if there is no error .

There are special cases when developers do not have the
device's voltage supply pin available in an application
powered by an external source. In order to feed the
programmer's output circuits, power supply from the
programmer must be switched on in such a case and its
voltage set at the same value as used in the application.
Yet as some voltage still “sneaks” into the programmer
from the application through the programming pins, the
programmer “sees” that there is some voltage present
and refuses to activate its own output voltage. For such a
case the following option is available: Program settings
→ Others → Al low interna l and external supply
voltages coll ision .

WARNING: Activat ing this option in other si tuations
could damage the programmer!
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Programmer Settings
Each time a particular programmer is selected (FORTE or
PRESTO), the programmer settings window is displayed
allowing the user to set the voltage used and some other
important programming options.

If you are using an external power source for feeding the
application, the During programming option must not
be checked.

Fig. 21: Programmer settings

The current voltage is continuously displayed in the top
right corner of this window.

Should an error i.e. overload occur, a warning appears at
this place.

The output voltage in the idle state if it is turn on can be
changed only if it is allowed under Options → Program
sett ings → Others → Allow to change supply vo ltage
level when it is on (FORTE only).

If a voltage is present at the VDD pin, you can stop the
running microcontroller application by pressing the Reset
button and restart it by pressing the same button again.

Fuses and Working with Them
Characteristics of the device (fuse) to be programmed
can be set in the Configuration window. Changes in
fuses can be saved by choosing File → Save or File →
Save project....

If the given .hex file of device includes definitions of its
fuses, fuses are saved in it.

Fuses are saved together with a project in the case of
Atmel microcontrollers and memory chips. If you are
working with these, right-click the Configuration window
once you have set the fuses and use the Learn fuses
option.

If the Options → Program settings → Programming →
Reload fi le before every programming opt ion is
active, the software reloads current file after the
Program button is pressed. If, however, fuses are not
saved in current file and no project is created from which
fuses could be used, the configuration memory initializes
into the default state before each programming
procedure. This can be avoided by deactivating the
Program sett ings → Files → Erase configurat ion
memory before fi le reading option.

Many devices have specific requirements for fuse
settings. Further information on how to correctly set their
fuses can be found in the particular device data sheet.

5.3.5 Programming
Select the file that you want to program by choosing File
→ Open.. . .

Once the file opens, you can see the current code/main
memory, data memory and configuration memory (fuses).
If you cannot see these windows, activate them under
the View menu.
The memory being programmed can be manually
modified at any time by simply marking the required
location and rewriting its value from the keyboard. If you
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want to save such a modification, choose File → Save,
Fi le → Save as . . . or Fi le → Export da ta memory to
file....

Important warning
It is recommendedto checkthe programmer
settingsandfuse settings before startingthe
actual programming asanerror inthese
parameters could damagethe device oreven
the programmer.

The programming process is triggered by choosing
Device → Program or by clicking the Program button.

In some devices, the system checks the Device ID (device
electronic signature) and the code/data protection bits
before launching the programming process. If the ID does
not match the selected device type, a warning message is
displayed.

Displaying of this warning message is frequently caused
by a fault in the interconnection of the device and the
programmer.
If things are in order, the programmer performs the
following operations: erases the device, checks the
erasure, programs the device and checks the
programmed device.

If only a particular memory of a microcontroller needs to
be programmed, it can be done by choosing the
corresponding item in the Device → Program menu or
by clicking the pull-down arrow next to the Program
button on the button bar. Depending on the device type,
the following options may be available: program code/
main memory, program data (EEPROM) memory, program
configuration memory or program all.

Differential Programming
The Device → Program menu offers a possibility of
differential programming, provided the device to be
programmed supports it. If selected, the existing memory
content is read first and only cells that differ are then

programmed.

Differential programming is useful for development during
which content of the programming data changes very
often, but the changes are tiny. As only changed cells are
overwritten, the differential programming is advisable for
devices with a low number of writing cycles. It can also be
faster than the conventional re-writing of the whole
memory content.

5.4 Further Features
The following section focuses on selected additional
functions of UP available for device programming.

5.4.1 Setting the GO
Button

ASIX programmers feature a GO button, which allows the
user to trigger the programming process without a
computer mouse or keyboard.

The function of the GO button can be set under the
Options → Key shortcuts menu in the GO button field
to suit user's needs.

The UP software must be running if the user wants to use
the GO button, but may be minimized on the screen.

Additional settings associated with the GO button can be
found in Settings for Programming During Development.

5.4.2 Mass Production
The mass production function is available under the
Device → Program → Mass production menu. It can
also be called up by clicking the arrow next to the
Program button on the toolbar.
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Fig. 22: Mass production

The actual programming can be triggered by clicking the
Program button in the Mass production dialog
window.

The function of this button is identical to the Program all
or Program all except data memory options
depending on the state of the Don't program data
EEPROM checkbox in the Mass production window.

This dialog window also displays a counter of devices
programmed. Depending on the program settings, the
counter can also be displayed in the status bar. For
further information on settings see Production
Programming Settings.

The counter displays the number of programmed devices
in both the mass production mode and the standard
mode.

Pressing the Counter reset button zeroes all the mass
production counters. This operation cannot be undone.

The choice "Auto programming" causes that the device is
programmed after it has been connected, the connection
test is done by reading the Device ID.

The programming can be launched by connecting
external power supply (VDD).

When the "Open this form after start" setting is enabled,
the form opens after program start or after project file
open, if it is used.

5.4.3 Serial Numbers
The Serial Numbers function programs the serial number
or another sequence of characters in the selected
memory location.

Fig. 23: Serial numbers

Once the serial numbers are activated and their type set
up under Options → Program settings → Serial
numbers, a window with the current serial number opens
offering the possibility to manually write a serial number
in the memory HEX editor, to specify where it should be
written and if the system should proceed to the next
sequential number.

Serial numbers can be:

• Computed

The computed serial numbers must always be written in
the same selected position in the device such as the
code/main memory, data memory or an ID position, for
example. The serial number is always expected to be a
number in decimal or hexadecimal format and may be
coded as a 4-bit combination (one to four characters per
word) or as an ASCII character (one or two ASCII
characters per word). If the code/main memory is used for
Microchip microcontrollers, you can choose RETLW
instructions. Then RETLW instructions are written in the
given address of the code/main memory together with a
parameter corresponding with the serial number.

• Taken from Fi le

A single serial number can be distributed in more than
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one device memories (the serial number itself directly to
the program, the equipment address to the data memory,
and the serial number again to ID positions in order to be
able to read it from a locked device, for example).

Note: A word is understood as one memory position.

Fig. 24: Serial number settings

A file for logging the programmed serial numbers can be
selected under Options → Program settings → Serial
numbers .
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The numbers themselves are logged in case of calculated
serial numbers while their labels are logged in case of
serial numbers taken from a file - see Format of Files with
Serial Numbers.

Except for the serial numbers also the date, time and the
result of the programming are writen to the file. For the
devices for which the revision reading is supported, the
revision number is also written to the file.

Format of Files with Serial
Numbers
Files containing definitions of serial numbers are text files
that can easily be created in third-party programs. *.SN or
*.TXT are recommended file extensions.

A serial number record has the following form:
[comment] label: data record, data record, . . .,
data record;

Semicolons are obligatory at the end of records.

• Comment is any string containing no colon ':'.
Comments are optional. If a colon cannot be found in
the whole serial number record, the record is ignored
(understood as a comment). It is also possible to write
a comment behind two slashes '//'.

This is just a comment;
// Also this is a comment .

• White character is a space, tabulator or end of line
(CR+LF).

• Label is a string identifying the serial number. This
string is compulsory. The label must not contain white
characters, colons or semicolons.

Data Record
A data record consists of an address and data items in a
chain following this address.
Each item can be written in hexadecimal form (e.g. 2100)

or a numeral base in which the number is written in can
be explicitly defined.
For example, b'10101010' means the same as h'AA',
d'170' or just AA. 'A ' means d'65' (ASCII character itself).

Example record for PIC16F628A:
2100 05 55 54 means to save data 05h, 55h, 54h in
addresses 00 to 02 of a data memory.
The code/main memory which stores the serial number
can also be specified by the word “CODE.” or “PROG.” or
just “P.”.

The data memory should be specified by the word
“DATA.” or “EE.” or just “E.”.

“ID” or just “I” is used for the memory of ID positions.

These words are always followed by an address inside the
specified memory.

Example:

EE.00 05 55 54 means to save data 05h, 55h, 54h in
addresses 00 to 02 of a data memory.

Notes
• * There is no specifier for the configuration memory, it
would make no sense.

dsPIC – addresses of 24-bit words are to be written in for
all addresses (i.e. an internal dsPIC address of 24h is 12h
here). For a data (EEPROM) memory addresses of 16-bit
words are to be written in, i.e. as they go one by one
through the microcontroller.

• Autonomous memory chips (I2C, SPI) have only the
code memory. If a non-existent memory is specified,
an error is reported.

Example of File with Serial Numbers
Comment at the beginning;
sn1: 0000 34 45 56 67,

2100 01 02 03 04; serial number 1
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sn2: 0000 45 56 67 78, 2100 02 02 03 04;
sn3: 0000 56 67 78 89, 2100 03 02 03 04;
note

sn4: 0000 67 78 89 9A, 2100 04 02 03 04;
sn5: 0000 78 89 9A AB, 2100 05 02 03 04;
sn6: 0000 78 89 9A AB, 2100 06 02 03 04;
sn7: 0000 78 89 9A AB, 2100 07 02 03 04;
sn8: code .0001 3F00 3F01 3F02 3F03,
data .0002 'x' '4' '2';
sn9: prog.0001 3F00 3F01 3F02 3F03,

e .0002 'x' '4' '3';

5.4.4 Calibration Memory
Support

Some devices contain a calibration memory containing
factory-preset device calibration. The loss of its content
can cause a fault in the device functionality. For this
reason we have tools allowing users to work with the
calibration memory.

Working with Calibration
Memory When Erasing a Device
in UV Eraser
Calibration data should be saved prior to erasing a
device. To do so, choose File → Save calibration
data...

ou can retrieve it back by choosing File → Read
calibration data...

The program contains a function for verifying whether a
device has been erased correctly: Device → Blank
check. When this command is used, the program displays
data from the calibration memory.

Working With Calibration
Memory in Devices With Flash
Memory
When these devices are erased, the content of their
calibration memory is preserved.
If you really need to erase the calibration memory for
some reason, you can do so by choosing Device → Erase
→ Erase all (including calibration) .

Advice

New Flash devices with a calibration memory (such as
PIC12F629) contain so called 'bandgap bits', which form
part of the device calibration. These bits can be found in
the configuration word and are erased too if the
command Device → Erase → Erase all(including
calibration) is executed!

5.5 Program Controls

Fig. 25: Controls of UP software

1) Title bar with the open project name or file
2) Menu
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3) Toolbar
4) Currently selected programmer
5) Currently selected device
6) Programmer settings window
7) HEX editor window for code/main memory
8) HEX editor window for data memory
9) Configuration window
10) Status bar

5.5.1 Toolbar
A toolbar is a panel with quick selection buttons located
under the program menu (see Program Controls).

If you want to remove the toolbar, simply uncheck the
Display icons and descriptions on the toolbar button
options in the Settings menu as described in Program
settings.

5.5.2 Status Bar
The status bar is a panel in the bottom part of the window
(see Program Controls). It presents information on the
programmer, the device, changes to the file since the last
saving, etc.

Individual parts of the status bar react to double-clicking
and to the context menu that opens after right-clicking.

If you want to hide or re-display the status bar, choose
Program sett ings → Panels → Display the status bar
in the lower part of the window .

5.5.3 Menus
The following texts describe in detail individual items in
the UP software menus.
Menu commands can be triggered with mouse by clicking
on a particular menu item or from the keyboard by
pressing the key together with the shortcut, i.e. the

underlined letter in the menu.

The menu bar consists of the following menus
(categories):

• File Menu

• Edit Menu
• View Menu
• Device Menu
• Options Menu
• Help Menu

File Menu
File → New
Keyboard shortcut: Ctrl+N

The program creates a new empty file. If the currently
open file has not been saved, the program prompts the
user to save it.

File → Open...
Keyboard shortcut: Ctrl+O

The program opens the Windows standard dialog listing
the files saved on the disc. The supported file formats are
described in Appendix C: Intel-HEX File Format. Files with
extensions .hex or .a43 are loaded as Intel-HEX, others as
binary. There are also filters available making it possible
to open all files as .hex or as .bin.

File → Open next file...
The program imports another .hex or .bin file with an
optional offset. This function is useful if the user needs to
load another file into device's memory. Files with
extensions .hex or .a43 are loaded as Intel-HEX, others as
.bin.
For example, this command provides for merging of
several .hex files (e.g. bootloader + program).
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When in Open next file dialog the user selects
Autoload next time, the file will be loading after the
main data file automatically. Then the file is listed in the
File → Open next: menu. Using this menu item the
autoload can be disabled again.

This way it is possible to autoload one file.

File → Open next:
When this menu item is enabled, it shows that the
automatic load of next file is enabled. By clicking this
menu item it is possible to disable the automatic file
load.

File → Reload actual file
Keyboard shortcut: Ctrl+R

The program re-opens (i.e. re-reads from the disc) the
currently open file. This command is useful if you know
that the file on the disc has changed and you want to load
these changes into the program.

If you are using Program settings → Files → Do
automat ic check for newer vers ions of actual fi le ,
the program automatically notifies the user of a change in
the currently open file and offers its reloading.

File → Save
Keyboard shortcut: Ctrl+S

The program saves the file on a disc. If you want save
your file under a different name than the current one, use
the Save As... command instead.

The program can skip unused locations of the memory.
See Program settings for details.

File → Save as...
The program saves the open file on a disc under a new
name using the Windows standard dialog.

The program can skip unused locations of the memory
while saving or not to save certain selected locations.

See Program settings for details.

File → Import data memory from
file...
Using the Windows standard dialog, the program reads
and imports the content of a data (EEPROM) memory
saved in a different file. This allows the user to load a
data memory if this has not been saved in the same file
as the code/main memory (this concerns ATmega8
microcontrollers, for example).

Important warning

Such a file, regardless of its content, is read from the zero
address as if it contained only the data (EEPROM)
memory. This means that a file generated normally by a
compiler cannot be correctly read using this command.

File → Open file with data memory
automatically
With this option selected, the program automatically
loads the file for the data memory alongside with loading
the file for the code/main memory. This option is active
only if a separate file is loaded for the data memory.

File → New project
Keyboard shortcut: Shift+Ctrl+N

This command creates a new project.

It is especially advisable to use project files if you
frequently switch between programming different device
types or if you are using several different programmers. A
project file contains all the corresponding settings and
provides for loading of all of them in one step.

File → Open project...
Keyboard shortcut: Shift+Ctrl+O

Using the Windows standard dialog, the program opens
an already existing project file saved on a disc. If an
additional file had been opened together with the project,
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such a file opens as well.

File → Save project...
Keyboard shortcut: Shift+Ctrl+S

Using the Windows standard dialog, the program saves
the current project under a new name. Saving of the
project under the same name is done automatically as
well as saving the program settings, for example.

In the Save project dialog using Load project
unlocked option it is possible to set that the project will
not be locked after load.

Using Add note option it is possible to add a note to the
project file, which will be shown after load of the project.

File → Close project
Keyboard shortcut: Shift+Ctrl+W

The program terminates the work with the currently open
project, saves the project file on the disc and returns to
the state in which it was before the new project was
opened.

File → Recent projects
This function remembers the last 10 opened projects.
Clicking the name of one of them opens the project.

File → Read calibration data.. .
Using the Windows standard dialog, the program opens a
file with the calibration data and loads the data in the
memory.

File → Save calibration data...
Using the Windows standard dialog, the program creates
a file with the device's calibration data previously read
from the device connected to the programmer. This
calibration data can be reloaded using Read calibration
data if the device gets erased in the meantime.
For further information on the program's support of work
with the calibration memory see Calibration Memory

Support.

File → Export to bin...
This command saves binary data from the code/main
memory, from the data memory or from ID positions in a
selected file.

16 or 8 bits word width can be selected for the data to be
saved.

File → Exit
Standard Windows keyboard shortcut: Alt+F4
Keyboard shortcut: Alt+X

Warning
If closingof the program isforced by theTurn
ComputerOff commandand the program
does not receivethe user's confirmation,the
systemclosesit forcibly aftersometime
without savingthe openfile orsettings.

If the program iscurrentlyworkingwiththe
hardware, it refusesallsystem's requeststo
turnoff and can be seenas “not responding”
by the system.

This command closes the program. If the open file has
changed, the program prompts the user to save the
changes.

Edit Menu
Edit → Fill with value.. .
The program fills a memory location with a specified
value. This command is used especially for erasing (filling
with ones) or zeroing (filling with zeros) a particular
location. Yet it can be filled with any value or with random
data.

When the Fill with value... command is called, the
program presets the selected memory according to the
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active window. If a memory location was highlighted
before calling this command, the program presets the
marked location for filling in.

A memory location can be selected by holding the Shift
key and clicking by mouse or moving by means of the
cursor keys (arrows). For further information on
highlighting a location see HEX Editor Windows.

Edit → Text insert...
This command saves a text in ASCII or in hexadecimal
format into a selected memory location. Ends of lines can
be coded as NULL, CR, LF or CR+LF characters.

Individual bytes can be inserted as well as saved in
RETLW instructions (this applies only to the code/main
memory working with Microchip microcontrollers).
Note: Microchip PIC RETLW instruction means return with
a constant value in the work register – this instruction is
frequently used for creating tables.

If the Text insert... command is called, the program
presets the selected memory and the starting cell
according to the current window and the selected cell.

Edit → Fill selected location with
RETLW
This command fills the selected Microchip
microcontroller's memory location with RETLW.

The command can be called only from an open HEX
editor. It is also available through the context menu (right
mouse click) in the editor.

A memory location can be selected by holding the Shift
key and clicking by mouse or moving by means of the
cursor keys (arrows). For further information on
highlighting a location see HEX Editor Windows.

View Menu
View → Code/main memory
This command opens or closes the code/main memory
HEX editor window. For more on HEX editors see HEX
Editor Windows.

View → Data memory
This command opens or closes the data memory HEX
editor window. For more on HEX editors see HEX Editor
Windows.

View → Boot memory
This command opens or closes the boot memory HEX
editor window. For more on HEX editors see HEX Editor
Windows.

View → Configuration memory
This command opens or closes the configuration memory
HEX editor window. For more on HEX editors see HEX
Editor Windows.

View → Console
This command opens or closes the console, where the UP
can write details about programming.

View → Display code/main memory
Keyboard shortcut: Alt+F10

This command displays the code/main memory HEX
editor. If it is already displayed, it moves it to the front
(the editor gets focus). For more on HEX editors see HEX
Editor Windows.

View → Display data memory
Keyboard shortcut: Alt+F11

This command displays the data memory HEX editor. If it
is already displayed, it moves it to the front (the editor
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gets focus). For more on HEX editors see HEX Editor
Windows.

View → Display configuration
memory
Keyboard shortcut: Alt+F12

This command displays the configuration memory HEX
editor. If it is already displayed, it moves it to the front
(the editor gets focus). For more on HEX editors see HEX
Editor Windows.

View → Display programmer form
Keyboard shortcut: Ctrl+P

The programmer form is always visible. This function
moves the programmer form to the front (the editor gets
focus).

Device Menu
Device → Program
Keyboard shortcut: Shift+F5

This command opens a sub-menu with programming
options. Some items may be inaccessible for certain
device types.

r Program all
Keyboard shortcut: F5

This command erases the device, checks the erasure,
programs it and verifies the programming result in the
whole device. The Device ID check and the Code/Data
Protection check are performed prior to this operation.
The behavior of this command is influenced by the
program settings - see Program settings.

r Program all except data memory
A keyboard shortcut can be assigned in Options → Key
shortcuts .

This command works the same as Program all with the
exception that it does NOT erase, program or verify the
data memory.

Devices without a data memory do not have this
command available and their programming is done using
the Program all command.

This command cannot be used in some cases that use
Code or Data Protection. For these, the program offers
the command Erase whole device and program also
data memory (with data currently in the editor).

r Program code/main memory
A keyboard shortcut can be assigned in Options → Key
shortcuts .
This command erases the code/main memory, checks the
erasure, programs and checks the programming result.
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r Program data memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command erases the data memory, checks the
erasure, programs and checks the programming result.

r Program configuration memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command programs the configuration memory and
ID positions (if device contains them) and checks the
programming result

r Program differentially
Keyboard shortcut: Ctrl+F5

This command programs the device applying the
differential method. This means that it reads the device
and programs only those cells the content of which differs
from the editor.
This command is available only for those devices that
support such treatment (not all devices do).

If a device has the Code/Data Protection active,
differential programming makes no sense. The program
performs complete programming instead, including
device erasure.

r Differential program data memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command programs the data memory applying the
differential method. Its function is identical with
differential programming of the code/main memory.
This command is available only for those devices that
support such treatment (not all devices do).
If a device has the Code/Data Protection active,
differential programming makes no sense. The program

performs complete programming instead, including
device erasure.

Differential programming of a data memory should be
used for AVR microcontrollers if the user needs to
reprogram the data memory only without previously
erasing the device.

r Mass Production
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command opens a window for easy programming of
several identical devices with the same or very similar
program(s) (except their serial numbers and the like). For
further information see Mass Production.

Device → Read
Keyboard shortcut: Shift+F6

This command opens a sub-menu with device reading
options. Some of them may be not available for certain
device types.

r Read all
Keyboard shortcut: F6

This command reads the content of the whole device.

r Read all except data memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command reads the content of the whole device
except the data memory.

r Read code/main memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command reads the content of the code/main
memory.
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r Read data memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command reads the data (EEPROM) memory.

r Read configuration memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command reads the configuration memory and ID
positions (if device contains them).

r Read address
This function enables reading of data from user filled
address, it supports MCUs ARM via SWD interface.

Device → Verify
Keyboard shortcut: Shift+F7

This command opens a sub-menu with device memory
content verification options. Some of them may be not
available for certain device types

r Verify all
Keyboard shortcut: F7

This command compares the content of all device
memories with the current content of HEX editors.

r Verify all except data memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command compares the content of all device
memories except its data memory with the current
content of HEX editors.

r Verify code/main memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command compares the content of the code/main
memory with the current content of code/main memory's
HEX editor.

r Verify data memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command compares the content of the data memory
with the current content of data memory's HEX editor.

r Verify configuration memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command compares the content of device's
configuration memory and ID positions (if device contains
them) with settings in the Configuration window.

Device → Erase
Keyboard shortcut: Shift+F8

This command opens a sub-menu with device memory
erasing options.

Erasure verification (blank check) is automatically
performed after each erasing. This verification can be
skipped by choosing Options → Program settings →
Programming → Do not per form blank check af te r
erasing. This can save time with some devices.

r Erase all
Keyboard shortcut: F8

This command erases the whole device.
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r Erase code/main memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command erases the code/main memory. It cannot
be used if Code/Data Protection is active.

r Erase data memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command erases the data memory and verifies it. It
cannot be used if Code/Data Protection is active.

Device → Blank check
Keyboard shortcut: Shift+F9

This command opens a sub-menu with device erasure
verification options. Some of them may be not available
for certain device types.

r Blank check all
Keyboard shortcut: F9

This command verifies whether the device is correctly
and completely erased.

r Blank check all except data memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command verifies whether the device except the
data memory has been correctly erased.

r Blank check of code/main memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command verifies whether the code/main memory is
correctly erased.

r Blank check of data memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command verifies whether the data memory is
correctly erased.

r Blank check of configuration memory
A keyboard shortcut can be assigned in Options → Key
shortcuts

This command verifies whether the configuration memory
and ID positions (if device contains them) are correctly
erased.

Device → Select device
Keyboard shortcut: F4

This dialog allows you to select a device type to be
programmed. Some memory types need to have their
data organization selected after the device type
selection.

Only devices supported by the currently selected
programmer are displayed in the dialog window. If you
want to select a device not supported by the current
programmer, select a different programmer type first.

For further information on selecting a device see Device
Type Selection.

Device → Device info
Shows a window with information about connecting the
selected device to the programmer.
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Options Menu
Keyboard shortcut: Shift+F10

The Options menu holds all the possible settings of the
UP program. There is a great number of setting
parameters. If you are not sure that all settings are
correct , you may use the Load defaults button, which
returns all the settings to the initial (factory) state.

Advice
Program settings → Load defaults button renewsthe state of
allsettingson alltabs, i.e.eventhe colorsettings,forexample.

Options → Program settings →
Programming
Keyboard shortcut: Shift+F10

This tab provides for setting all the general programming
parameters .

Sett ings concerning the programmer and the
communication port are described in Programmer
Selection .

A special Device → Select device window is avai lable for
sett ing the device type.

、Reload file before every programming
The program reads the current file with programming
data from the disc before each and every request to
program a device if this option is checked.

If the use of serial numbers is also activated requesting
reading the current file prior to programming, then the
file is read first and only then is the current serial number
written.

、Keep manually modified data
When this choice is active, the file load before
programming does not rewrite manually changed data.
This choice affects only behavior of the file reload before
programming.

、Warn before file load, when data in
some editor have been changed
When before load of the file before programming it is
found that data in some editor have been changed, the
program shows a warning.

、Warn, when the loaded file has not
changed
Program shows a warning, when the content of the
loaded file has not changed from the previous
programming.

、Program file locations only
The programming changes only the positions contained in
the file. First it reads the programmed device content,
then it reads the file content which replaces the data read
from the device. The addresses which are not contained
in the file hold the value read from the device. Fina lly the
memory is programmed.

、Ask before erasing
With this option checked, the program asks for user
confirmation before erasing a device.

、Ask before programming of OTP / Flash
/ Code/Data Protection / differential
A set of options determining which user confirmation
dialogs will or will not be displayed by the program.

The program asks just once except the Code/Data
Protect ion programming . I f the program needs to ask
the user for additional information before actual
programming (such as Device has Code or Data
Protect ion. Do you want to erase it entirely? ) , it
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does not ask for further programming confirmation after
answering the first dialog.

r Display fuse warning messages
The user can choose if warning messages should be
displayed for some fuses. It is recommended to leave this
option on.

r Except for programming: Close status
window
This option closes the status window if no error occurs
during erasing, blank check, programming verification
and reading.

r After programming: Close status
window
This option closes the status window if no error occurs
during programming and the subsequent verification.

r Beep after successful finishing
With this option active, the program calls up the standard
Windows system beep if the operation (such as erasing,
programming, etc.) went smoothly.

r Beep after unsuccessful finishing
With this option active, the program calls up the standard
Windows system beep if an error or warning occurs during
the operation (such as erasing, programming, etc.).

r Turn off all sound for UP
With this option on, the program does not produce any
sounds.

r Delay for VDD switching on/off when
supplied from programmer
This option is important for programming PCB-placed
devices via an ICSP cable. It determines the length of the
delay after voltage is connected to or disconnected from
a device.

Both PRESTO and FORTE feature an overcurrent
protection. This means that a test for excessive current of
approximately 100 mA in power supply voltage is
performed after connecting power to the device and
expiration of the delay time set in Switch on.

Similarly the delay time set in Discharge specifies how
late after switching the power supply off a check should
be performed if no voltage is present any longer at the
pin.

If a blocking capacitor is connected to the device's power
supply pins (recommended), the voltage at the pin
changes more slowly. This could cause problems during
programming, but they can be eliminated by prolonging
the charging and discharging time.

Too long a time increases the risk of damaging the device
if connected incorrectly while too short a time could
cause programmer's circuits to still detect excessive
current flowing to the application's capacitors. A formula
for an approximate determination of the necessary time
can be found in Appendix B: Use of ICSP.

r Do not perform Device ID check before
programming
This option switches off the Device ID check before
programming.

r Do not perform blank check before cfg
word programming
Most rewritable devices can overwrite the configuration
word without erasing the whole device content. Skipping
the blank check of the configuration word utilizes this
possibility, i.e. the program ignores the not erased word.

This option does not apply to the whole-device
programming in which the device is erased completely. It
concerns only the configuration word and its overwriting.
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r Do not perform blank check after
erasing
This option speeds up the programming process and is
useful especially for debugging. The danger is that an
incorrectly erased device is subsequently incorrectly
programmed and the fault only gets detected later. On
the other hand, a device is erased incorrectly only once in
several hundred attempts.

r Do not erase device before
programming
The device is not erased before programming.

r Do not erase data memory before its
programming
This option only concerns programming of Atmel AVR
devices e.g. ATmega8. Data memory of this family
devices does not require to be erased before
programming. If this option is not activated, whole device
will be erased before programming.

r Do not verify unprogrammed words at
the end of the memory
If there is a location at the end of the code/main memory
containing only default values, it is not verified.

This option speeds up the verification of the programmed
memory as the content of the “empty” memory at its end
usually does not matter.

r Do not verify
This option completely switches off the verification of a
programmed device. Such off-switching can radically
speed up the programming process during development.
This option must not be activated for production as
correctness of the programmed content would not be
guaranteed.

r Verify with two supply voltages
This option is available only for FORTE and only for the
internal power supply from the programmer. It allows you
to perform the verification at two different power supply
voltages defined by the user.

Some device manufacturers recommend to verify the
content after production programming at two different
voltages corresponding with the approved range of the
device's power supply voltages.

Options → Program settings →
Panels
Keyboard shortcut: Shift+F10

This part of the Options menu allows you to alter the
application's appearance. The user can set where and
how some control components are to be displayed.

r Display selected device on toolbar
In addition to the status bar, the selected device is also
displayed in the toolbar.

r Display selected programmer on
toolbar
In addition to the status bar, the selected programmer is
also displayed in the toolbar.

r Display the status bar in the lower part
of the window
This option determines whether the status bar is to be
displayed or not.

r Display icons on toolbar buttons
Icons of individual tools are displayed in the toolbar.
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r Display descriptions on toolbar buttons
Tool names are displayed next to individual tools in the
toolbar.

If the Descr ipt ions on toolbar buttons to the right
option is used, the total toolbar height is reduced to a
half.

r Show mass production counter in
status bar
This option displays the mass production counter in the
status bar. The counter shows the number of devices
programmed and the number of devices programmed
successfully.
If you use the Count all actions option , the counter
includes all actions performed with the device (such as
reading, erasing, data memory programming, etc.).

Show values description displays explanatory notes to
individual counter items for easier understanding.

If you want to exclude operations that triggered a
warning from the correct operations, use the If action
ends with warning assume as erroneous option.

The choice Reset counters on project open causes,
that the counters are reset on any project file load,
including automatic project load during program start.

Counter style allows you to choose whether the counter
should display the good/bad or good/total figures.

The Counter reset , button can be used for zeroing the
counters while their initial values can be set in the Preset
counter values fields.

Options → Program settings → Files
Keyboard shortcut: Shift+F10

This tab holds all the settings for reading data from and
saving data to files.

r File save style
The File save style panel offers the possibility not to
always save all areas of all editors in the file, but rather
only some. UP then asks questions based on the saving
style settings before saving different project editors.

r Do automatic check for newer version
of actual file
This option helps especially in debugging a program. The
program re-loads the file if it detects a change in the file
modification date.

r Never ask and never save changes to
data file
When this option is enabled and data in an editor have
been changed, before opening of an other file, before
closing of the application etc. the application will not ask
and will not save the file which is currently open.

r Check device type when loading .hex
file
If the device type has been saved in the corresponding
Intel-HEX file and it does not agree with the currently
selected device type, the program points out this
discrepancy.

r Save device type into .hex file
The program adds one more line below the end of file
command specifying the type of device for which the file
is being saved.

Such a modified file does not comply with the Intel-HEX
format, but most programs working with the Intel-HEX
format ignore this line.

For further information about the Intel-HEX format see
Appendix C: Intel-HEX File Format.
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r Warn when loaded HEX does not
contain CFG memory data
If the file does not contain configuration memory data
and the data are expected for the chosen device, a
warning message is displayed.

r Warn when loaded HEX is not aligned
to word size.
If the file is not aligned to the word size of the memory of
the device, a warning message is displayed.

r Binary file loading and saving style
This panel provides for the setting of how .bin files are to
be loaded and saved if a device with more than one byte
per word is selected.
Available options are: the program always asks before
loading or saving a .bin file (Ask if to load/save .bin as
Big or Little Endian), or without asking, the program
always loads files as Little Endian (Never ask, load/save
as Little Endian) or as Big Endian (Never ask, load/
save as Big Endian ).

r Save unused locations to .hex file
If not all positions are saved, the final file is smaller, but it
can cause difficulties as a cell is considered an “empty
position” if it contains only ones (e.i. FFFh, 3FFFh, etc.).
Yet this could be a meaningful instruction (3FFFh is
Microchip PIC addlw -1 instruction, for example).

As UP always saves files by larger blocks, (by eight or
sixteen bytes), the danger of losing an instruction by such
saving is rather small in reality.

If you use memory initialization prior to loading a .hex file
(which is recommended), even a program loaded from a
reduced .hex file will be correctly programmed as the
missing instructions are created “automatically”.

r Clear code/main / data memory / ID
positions before file reading
This location is filled with ones and only then a file is
loaded. This way all positions that are not saved in the
.hex file get erased.

This option is also important if no “empty” locations are
saved in the .hex file (see r Save unused locations to .hex
file).

r Erase configuration memory before file
reading
With this option activated, the configuration memory is
initialized before a file for code/main memory is loaded.

If no fuses are saved in the file, it is recommended to
deactivate this option. At the beginning of the work, the
user can set the content of the configuration memory and
then the fuses do not have to be set again if the file is
repeatedly loaded.

r Read data memory not from the file but
from the device
If you want to make sure that the content of the data
memory does not get overwritten, use the r Program all
except data memory option. If, however the r Program all
option is selected by accident (by unintended pressing of
the GO button, for example), the content of the data
memory would be erased.

For such cases, this option of Read data memory not
from the file but from the device is available. The
program fills in the given location with the memory
content of the device connected to the programmer.

Advice
This optioncouldcause unexpectedactionsduringwork
withthe programmersuchas switching the applicationon
orstartingthe UPprogram.
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r Read ID positions not from the file but
from the device
If you want to preserve the content of the ID positions,
use the Read ID posit ions not from the fi le but from
the device option. The program fills in the given location
with the memory content of the device connected to the
programmer before starting the programming itself.

Advice
This optioncouldcause unexpectedactionsduringwork
withthe programmersuchas switching the applicationon
orstartingthe UPprogram.

r Save fuses in UP instead of data file
This option allows to save fuses in ini file or UP projekt file
even for devices which by default have their fuses saved
in a data file.

r Project storing style
This panel allows you to set how projects should be saved
when exiting UP. Available options are: save
automatically, ask before saving or keep the original file
(i .e. do not save).

r Load last project on start-up
This option allows you to set if on the next UP start it will
open the project file, which was open on program
closing.

Options → Program settings →
Colors
Keyboard shortcut: Shift+F10

This is where you can change and save colors of HEX
editors so that they suit your needs and your aesthetic
preferences.
A front color, a background color and a font can be
selected for all the listed text segments.

Options → Program settings →
Editors
Keyboard shortcut: Shift+F10

r Code/main memory editor: show words
as bytes
Individual words can be displayed by bytes in case of
devices with 16-bit-long words.

r Code/main memory editor 8 words
wide
This option narrows the editor from the original sixteen
cells down to eight. The option is suitable especially for
small monitors. It can change automatically when a
different device type is selected.

The same option can be set for others memories:

r Data memory editor 8 words wide
r Boot memory editor 8 words wide
r Show only the lowest byte of word in
ASCII
When this option is activated, the program shows the
ASCII translation of only the lowest byte of word, which
can be useful especially for PIC MCUs.

r Mask ID positions while reading from
device, from file, etc.
Some manufacturers' specifications recommend saving
only masked data (with only four bits usable) in ID
positions. With this option activated, the program always
applies this bit mask when reading ID positions from
different sources.
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r Mask ID positions during direct user
input
With this option activated, the program applies the bit
mask to each user-modification of ID positions. For further
information see r Mask ID positions while reading from
device, from file, etc..

r Configuration memory editor: show cfg
word instead of fuses
This option is recommended for advanced users only. It is
not saved in the UP configuration file for safety reasons.

Direct editing of fuses is understood as direct writing of a
configuration word value in the hexadecimal form.

When a “non-translatable” configuration word is entered,
the program leaves the unrecognized items unchanged
unless the user changes them him/herself. This typically
concerns CP fuses having several bits but only two
values.

Options → Program settings → Serial
numbers
Keyboard shortcut: Shift+F10

For further information on working with serial numbers
see Serial Numbers.

r Serial numbers
This tab allows you to choose whether serial numbers are
to be used and if so then whether they should be read
from a file or computed and whether they should be
automatically written to the corresponding location.

r Prepare S/N before programming
This option prepares a serial number in the selected
memory location before the actual device programming.

r Find successor after programming
Once one programming procedure is successfully
completed, the system proceeds to the following serial
number. If this option is not activated, it is still possible to
proceed to the following number manually by clicking the
Next button on the Serial numbers tab – see Serial
Numbers.

r Prepare S/N after programming
This option causes that a serial number is prepared in the
selected memory location after the device programming.

r Serial number interval
This defines by what value the following serial number
will be larger or smaller.

r Log to file
By activating this option and by selecting a log file in the
field, information about correctly and incorrectly
programmed devices as well as the programming time is
saved in the selected file.

r After project load set actual SN
according to the last in the log
When this option is enabled, the last programmed SN is
read from the log file and when the programming is
logged as errorless the next SN is computed from the
read value else the last SN is set again.

The log file has to exist and the last record has to contain
a SN.

This function can be useful when the serial numbers are
enabled and saving of UP project files is disabled, in such
a case the actual SN will not update in the project file on
program close.
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r Serial number length (the number of
characters)
This field determines how many characters the serial
number can hold. For example, 4 characters provide for
the serial numbers 0001 to 9999 in base 10 (i.e. in
decimal form).

r Number base
This option defines the base of the serial number
characters. Base 10 and base 16 are available (i.e. the
decimal and hexadecimal forms).

r Code as ASCII
With this option activated, serial numbers are legible as
ASCII characters.

r Initial serial number
This field defines the initial value from which serial
numbers are to be computed.

r Next S/N
This field defines how the following serial number is to be
generated.

If The same is selected, the serial number does not
change. If One interval higher is selected, the following
number will be larger by the value of r Serial number
interval while if One interval lower is selected, it will
reduce by that value.

The Generated LSFR option generates the numbers in a
pseudo-random sequence. This means that the sequence
will always be the same if the same Initial serial
number and the same Serial numbers step is used.

The Manual option shows a field, in the serial numbers
window, where the serial number in the hexadecimal form
can be entered before programming. When this option is
selected, the serial number can be entered using the /sn
commandline parameter as well.

r Destination
This panel determines the memory location in which the
serial numbers are to be stored. Code/main memory,
data memory and ID positions are available as
options.

r Hexadecimal address of first word
This address defines where the first word of the serial
number is to start in the selected memory type.

r Fill with RETLW instruction
Individual words of the serial number can be filled with
RETLW instruction in Microchip microcontrollers. This
option is available only if the serial number is located in
the code/main memory.

r Characters per word
This panel determines how many serial number
characters form one word. Options of 1 to 4 characters
per word are available.

r Sequence
This panel sets how individual serial number characters
and words are to be ordered.

For example, if you have a base 10 serial number
consisting of four characters organized as 2 characters
per word and you are working let's say with 1234 as the
serial number, it will be saved in the following ways:
HiLo hilo: 12 34
hilo HiLo: 34 12
LoHi lohi: 21 43
lohi LoHi: 43 21

Options → Program settings →
Checksum
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r Show checksum in status bar
After enabling of this setting the checksum of the code
memory will be shown on the status bar.

When MD5 checksum algorithm is selected, the checksum
is shown after placing the mouse on MD5 text in the
status bar.

Note: Doubleclick on the checksum value in the status bar
will cause the value recalculation.

r Write checksum to log file
Enables writing of the loaded data file checksum to a log
file.

Note: The checksum is recalculated on data file load. This
function have to be enabled before the file load, else the
checksum value will not be written to the log file.

r Checksum algorithm
Using this choice the checksum calculation algorithm can
be chosen.

Options → Program settings →
Others
Keyboard shortcut: Shift+F10

r Update check settings
Here you can set if the program should ask for your
permission to connect to the Internet and check for
updates upon each start or not.

For further information see Updating UP.

r Allow internal and external supply
voltages collision

Warning
A collisionof powersupply voltagescan
damagethe programmerorthe application!

If you approve the collision of supply voltages, it allows
the programmer to connect its internal voltage to pin
VDD at times when it can already see a voltage present
there. This could damage both the programmer and/or
the application being programmed.

This option has been included for very specific cases. One
of them can be a request to program an application,
which does not have any VDD pin. Then the application
must be powered from its own source but the
programmer's output buffers must be powered from the
USB. Yet as the voltage at the application's data signals
“sneaks” through the protective diodes into the output
section of the programmer, the programmer can see a
certain small voltage present at VDD and refuses to
connect its own internal voltage to it.

r Do not show warning if internal 5 V is
switched on with 3.3 V device

Warning
High avoltage atthe device candamagethe
programmerortheapplicationbeing
programmed.

This option can be used to suppress the warning if a
higher voltage is switched on at the VDD output than the
value allowed for the particular device.

If there is a voltage convertor integrated in the
application between the device being programmed and
the programming interface, it might be useful to use this
option of programing at a higher voltage than what the
device has been designed for.

This option is available only for PRESTO.

r Allow to change supply voltage level
when it is on
In order to protect the application connected to FORTE
from damage, it is typically forbidden to change the
output voltage level if the voltage is currently connected
to the application. After activating this option, the output
voltage can be changed at any time within the range that
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the device being programmed can cope with.

r Allow external supply voltage for
devices requiring VPP before VCC.
For some devices their manufacturer requires the
programming voltage to be connected before the supply
voltage of the device. When the external supply voltage is
used, it does not comply with the specification. In this
case a warning is displayed, which can be permanently
disabled using this setting.

Disabling of this warning should be well considered. This
warning is displayed for devices for which the external
supply voltage violates the device manufacturer
specification.

r When using Windows Messages
disable other warnings
When controlled via Windows Messages the UP software
does not show any warnings, similarly like in quiet mode
on the commandline.

r Pin T during programming
With this setting it is possible to set a logical level during
programming on the T pin. The selected logical level will
be visible on the pin only when the supply voltage is
available at the VDD pin of the programmer.

In case that the T pin is used for programming, this
function will not be available.

This option is available only for FORTE.

r Pin T after programming
With this setting it is possible to set a logical level, which
will appear on the T pin after programming. The selected
logical level will be visible on the pin only when the
supply voltage is available at the VDD pin of the
programmer.
In case that the T pin is used for programming, this
function will not be available.

This option is available only for FORTE.

Options → Select programmer
Settings concerning the programmer and the
communication port are described in Programmer
Selection.

Options → Language selection...
Keyboard shortcut: Ctrl+L

A file with a different language localization can be
selected using the Windows standard dialog. This means
that one program installation can easily switch between
different user-interface languages.

Options → Keyboard shortcuts.. .
Keyboard shortcut: Ctrl+K

Using this dialog window you can define or change
keyboard shortcuts for most commands the programmer
is capable of performing.

This window also provides for setting the required
behavior of the GO button.

Options → Lock project
After a project file has been opened, it is locked against
unintentional changes. To unlock or lock it again this
function can be used.

When in project save dialog it was selected to Load
project unlocked, after load it will not be locked.

Help Menu
Help → Help on program
Keyboard shortcut: F1

This command opens the help that you are are just
reading.
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Help → List of supported devices
This command displays a list of devices currently
supported by the latest version of UP.

Help → Check Internet for updates
The program connects to the Internet and checks if you
are using the latest version.

Help → ASIX website
This command opens www.asix.cz, the website of ASIX
s.r.o. where you can find the latest drivers and manuals
for ASIX products.

Help → About
Basic information on the program and a contact to
technical support.

5.5.4 Programmer Settings
Window

All important settings concerning the programmer and
the applications to be programmed are displayed in the
programmer settings window.

The window appearance changes in accordance with the
selected programmer and device.

FORTE Programmer Settings
Window
Power supply from the programmer
This trackbar allows the user to set the voltage level
supplied to the application by the programmer.

In idle state
If this option is checked, the programmer supplies power
to the application even when not programming.

During programming
If this option is checked, voltage from the programmer
will be used during programming.

Reset
This button allows you to switch levels on the device's
reset pin between the level required for reset and high
impedance.

Reset is active if voltage is present on the power supply
pin.

Settings Associated with RX600
Microcontrollers
r Protect with ID
If this option is active, it programs also the OSIS(ID) value
during Configuration memory programming, this way it is
possible to lock the device bootloader access.

r Allow using Configuration Clearing
(erases TM, ID)
The Configuration Clearing erases a TM (Trusted Memory)
space. When the TM is in use, the use of this option
should be well considered.

The use of this option is the only possibility how to erase
OSIS(ID).

r Baud Rate
Using this option it is possible to set a communication
speed between the programmer and the programmed
device.

Settings Associated with PIC
Microcontrollers

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

http://www.asix.cz


Page 59

r Programming method
• HVP Traditional programming will be applied using a
voltage of 8 V to 13 V at pin P.

• LVP Programming utilizing the microcontroller's LVP
pin will be applied; only logical values of 0 or 1 are
present at programmer's pin P.

r Use PE
Programming utilizing the Use PE option can be applied
to PIC24 and dsPIC33 devices. PE stands for Programming
Executive and it is a programming method frequently
proving to be faster. The Programming Executive does
verification after programming, that is why UP does not
verify after PE programming.

Boot memory programming
This allows to select the boot memory region to be
programmed or checked.

Settings Associated with AVR and
8051 Microcontrollers
Oscillator frequency
An external oscillator or a functional internal oscillator
must be connected in the course of AVR microcontroller
programming. The frequency setting must match the
frequency at which the device's oscillator is really
running, after eventual dividers. The maximum speed of
communication with the microcontroller then depends on
the frequency of this oscillator.

Faster Programming with Slow Clock
If this option is active, once the device is erased, the
fuses are programmed at the maximum frequency of the
internal oscillator. This allows the programmer to
communicate with the device at a faster speed. At the
end of programming, the required value of the
communication memory including the clock speed is
programmed.
This option has its effect only if the whole device is

programmed.

Inverse Reset
With this option activated, the programmer generates an
inverse reset signal.

This option is appreciated if the application includes a
reset circuit that needs an inverse signal at the input
compared to the output signal sent to the microcontroller,
and if the programmer is connected via this reset circuit.

Write RC osc Adjustment
When this option is set, programmer will write the value
defined in the Configuration window to "RC osc
Adjustment" fuse. When it is not set, the value read from
the device will be written back to the fuse.

HVP
If this option is checked, the programmer uses the “high”
voltage at pin P for communication with the device.

This allows you to program a device with the external
RESET signal switched off.

Settings Associated with CH32V003
Microcontrollers
r Fast mode
When this option is set, programmer uses double speed
for communication with the microcontroller.

Settings Associated with I2C
Memory Chips
I2C Bus Speed
Select the maximum possible speed of the I2C bus. The
programmer switches on the internal pull-up of 2.4 kΩ
while working on the I2C bus.
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I2C Memory Address
Select the address of the I2C memory on the bus.

Settings Associated with SPI Flash
Chips
r Start address
Sets the address range for work with the memory. Start
address is the first address, where the selected
operation is executed.

r End address
Sets the address range for work with the memory. End
address is the last address, where the selected operation
is executed.

PRESTO Programmer Settings
Window
In idle state
If this option is checked, the programmer supplies power
to the application even when not programming.

During programming
If this option is checked, voltage from the programmer
will be used during programming.

Settings Associated with PIC
Microcontrollers
MCLR Pin Control
The logical value present at pin P1 (VPP) can be
controlled by the Run , Stop , Tristate and Reset buttons
in the idle state if a voltage is present.

The Reset button generates a resetting pulse.

Programming Method
• HVP Traditional programming is applied with 13 V
present at VPP.

• LVP Programming utilizing microcontroller's LVP pin is
applied, only logical values of 0 or 1 are present at
programmer's pin P.

Algorithm Programming
• Auto An algorithm is selected according to the voltage
currently present at VDD.

• Ucc=5 V The algorithm for fast 5 V programming is
used.

• Ucc=2.7 to 5.5 V The algorithm for slow
programming is used with the benefit of working at all
power supply voltages.

Use PE
Programming utilizing the Use PE option can be applied
to PIC24 and dsPIC33 devices. PE stands for Programming
Executive and it is a programming method frequently
proving to be faster. The Programming Executive does
verification after programming, that is why UP does not
verify after PE programming.

Boot memory programming
This allows to select the boot memory region to be
programmed or checked.

Settings Associated with AVR and
8051 Microcontrollers
Oscillator Frequency
An external oscillator or a functional internal oscillator
must be connected in the course of AVR microcontroller
programming. The frequency setting must match the
frequency at which the device's oscillator is really
running, after eventual dividers. The maximum speed of
communication with the microcontroller then depends on
the frequency of this oscillator.
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Faster Programming with Slow Clock
If this option is active, once the device is erased, the
fuses are programmed at the maximum frequency of the
internal oscillator. This allows the programmer to
communicate with the device at a faster speed. At the
end of programming, the required value of the
communication memory including the clock speed is
programmed.

This option has its effect only if the whole device is
programmed.

Inverse Reset
With this option activated, the programmer generates an
inverse reset signal.

This option is appreciated if the application includes a
reset circuit that needs an inverse signal at the input
compared to the output signal sent to the microcontroller
and if the programmer is connected via this reset circuit.

HVP
If this option is checked, the programmer uses the “high”
voltage at pin P for communication with the device.

This allows you to program a device with the external
RESET signal switched off.

Settings Associated with I2C
Memory Chips
I2C Bus Speed
Select the maximum possible speed of the I2C bus. The
programmer switches on the internal pull-up of 2.2 kΩ
while working on the I2C bus.

I2C Memory Address
Select the address of the I2C memory on the bus.

Settings Associated with SPI Flash
Chips
r Start address
Sets the address range for work with the memory. Start
address is the first address, where the selected
operation is executed.

r End address
Sets the address range for work with the memory. End
address is the last address, where the selected operation
is executed.

5.5.5 HEX Editor Windows
HEX editors are used for displaying the content of a
memory chip to be programmed.

Different colors are used in HEX editors to differentiate
between states of different cells to make it easy to see
which cells have been read from a file, which have been
successfully programmed, etc.
Colors may be user-assigned. This is especially
recommended for workstations with displays/screens
displaying only a limited number of colors.

Selecting an Area
An area can be selected in a HEX editor by holding the
Shift key down and pressing the cursor keys (i.e. arrows).

Once a required area is selected, it can be filled with a
required value. The values can also be filled with RETLW
instruction. These options are available in the context
menu (opens by mouse right-click).
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Code/Main Memory Editor
Menu: View → Display code/main memory

Keyboard shortcut to open the window: F10
Keyboard shortcut to close the window: Esc

The code/main memory editor displays the code/main
memory content or the content of the memory itself in
case of serial EEPROM chips (24xx, 93xx,... ).

Data Memory (EEPROM) Editor
Menu: View → Display data memory

Keyboard shortcut to open the window: F11
Keyboard shortcut to close the window: Esc

The data memory editor is used for displaying the content
of the additional memory in some devices (typically
EEPROM).

Not all devices have an additional memory. This means
the editor may not be available for some devices.

Configuration Memory Editor
Menu: View → Display configurat ion memory

Keyboard shortcut to open the window: F12
Keyboard shortcut to close the window: Esc

The configuration memory editor displays settings that
are to be programmed in a device, but are not part of any
of the above memory types.

The configuration memory editor content depends on the
selected device type. It is necessary to get acquainted
with the device's data sheet in order to get a closer
explanation of individual options in this window.
Not all devices need configuration data. This means the
editor may not be available for some devices.

Tips for Advanced Users
Even though the configuration memory may be presented
as a set of settings, in reality it is nothing more than a
memory that can be approached cell by cell. Due to this,
it is possible to display the memory in this way.

This can be achieved by activating Options → Program
sett ings → Editors → Configurat ion memory edi tor:
show cfg word instead of fuses option or by double-
clicking the configuration memory window.

The device's ID positions (do not mistake for Device ID)
can also be found in the configuration memory window. ID
positions can be programmed with values identifying the
device, such as the serial number, for example. ID
positions can always be read - even if the device is locked
against reading.

According to the recommendation of the Microchip, ID
positions should not be programmed with any value; only
a certain number of bits (typically 4) should carry data for
identification while other bits should be programmed with
the default value.

This can be achieved by activating Options → Program
settings → Editors → Mask ID positions... .

5.6 Running UP from
Command Line
The UP program can alternatively be controlled from the
command line.
The program itself makes sure that it always runs in one
instance only (with one class name). Should a second
instance (with the same class name) be started,
parameters from the command line are transferred to the
first instance for execution. Only the /p, /pdiff, /blank, /
verify, /erase, /read, /noe, /eeonly, /noboot, /boot, /code, /
cfg parameters are transfered to the running instance. UP
can be started in more instances using different class
name, see /wnd in List of Parameters.
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On the commandline it is recommended to use project
file, it contains important settings for programming. Some
project settings can be modified using commandline
parameters. Commandline parameters have higher
priority than the settings from the project defined on the
commandline.

5.6.1 List of Parameters
UP.EXE [{/ask | /q | /q1 }]
[{/e File_with_eepromm.hex | [/noe]} ] [{/p |[/pdiff]| [/
o ]} File.hex | File.ppr] [/df File.hex] [/part
device_name] [/eeonly] [/erase][/w [nd]
up_window_class] [/cfg] [/devid] [/blank] [/verify File]
[/read File] [/s SN_programmer's][/progname name] [/
noboot ] [/boot ] [/code ] [/getpartrev] [/sn
serial_number] [/conf file]

Legend
• Text presented here in bold is to be keyed in in the
command line exactly as printed here.

• Text presented here in italics is to be replaced by the
corresponding parameter. For example, file_name
should be replaced with the real name of a file to be
opened.

• Text in braces {} separated by the | sign represents a
selection of one of the presented options. For example,
{ A | B } means “choose either A or B”.

• Text in square brackets [] presents an optional
parameter – it can be keyed in but does not have to.

• Text in quotation marks “ ” is a mnemonic.
/ask To be used linked with /p. The program

always asks if it is to continue before
launching the actual device programming
even if the program settings specify not to
ask. The dialog displays the selected device
type.

/q /quiet “Quiet” mode. The program does not ask
any questions. If it needs to display a
dialog, the execution finishes with an error.
See UP program return codes. An external
application can monitor UP work flow by
ProgressBar value reading, see Work flow
monitoring.

/q1 “Quiet” mode 1. It works same like the /q
parameter, but shows the Status form,
which is closed after programming
regardless of errors. UP does not provide
with the ProgressBar value when the /q1
parameter was used.

/e file “EEPROM” file. For keying in the name of a
file with data for data memory, if needed. If
the file name contains space(s), it must be
enclosed by inverted commas.

/noe “No EEPROM”. The program skips the
device data memory programming. If this
parameter is used for MSP430
microcontroller programming, the
information memory is erased and
programmed.

/p file To “program”. The keyed in file will be
programmed. The file can be a data file,
e.g. hex file, or UP project file. If the file
name contains space(s), it must be
enclosed by inverted commas.

/pdiff file To “program the difference”. The keyed in
file gets programmed by the differential
algorithm. If the file name contains
space(s), it must be enclosed by inverted
commas.

/o file To open. The keyed in file opens. The file
can be a data file, e.g. hex file, or UP
project file. This parameter is optional. If
the file name contains space(s), it must be
enclosed by inverted commas.
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/df file When there is UP project file specified after
the /p or /o parameter and user wants to
use the project and to change data file
only, the /df parameter with the new data
file name can be used for this purpose. If
the file name contains space(s), it must be
enclosed by inverted commas.

/eeonly This executes the selected operation only
with the data (EEPROM) memory or only
with the information memory in the case of
MSP430.

/part name This selects the required device in
UP.

/erase This erases the device.

/wnd class name A different window class name. More
than one instance of the UP program can
be started using this parameter (running
then simultaneously). Each new instance of
the running UP must have a different class
name.

/cfg If this parameter is used in combination
with parameter /p, only the configuration
memory gets programmed. This is useful
for programming AVR microcontrollers, for
example, which can be switched to a faster
oscillator and then programmed much
faster.

/devid If this parameter is used in combination
with parameter /p, the software only
checks the device's Device ID.

/blank This checks device erasure (blank check)
and returns an error code if the result is not
OK.

/verify file This verifies the device.

/read file This reads the device and saves the read
content to the file.

/s programmer_SN This makes it possible to
select a programmer by its serial number.
The serial number is to be keyed in the way
it is displayed in the UP program and
printed on the programmer bottom.
Example: 016709 or A6016709. When *
sign is used instead of the serial number,
then any available programmer of the
selected type is used.

/progname name This makes it possible to
select a programmer by its name such as
PRESTO or FORTE for example.

/noboot This skips programming of the MSP430 boot
memory.

/boot This performs the selected operation only
with the MSP430 boot memory.

Note

PIC32 microcontrollers also have a boot
memory. This, however, uses variables and
a data memory form for programming, so it
works with parameters for a data memory
and not with parameters for a boot
memory. A similar situation can be found in
the information memory of MSP430 and
CC430 microcontrollers.

/code This performs the selected operation only
with code or main memory.

/getpartrev Only reads the revision of the device
and returns revision + 0x10000 as the error
code.

/sn serial_number Using this parameter it is possible to
enter the value of the serial number, which
is then written to the address in accordance
with the serial numbers settings. In the
settings, the serial numbers have to be
configured as Computed, Manual. The
number is entered as hexadecimal, e.g.
1234ABCD.
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/conf file When UP closes, it saves its console
content to the file, but only when the
operation was started from the
commandline.

Note: When no parameter requesting an operation is
used, the UP starts and keeps running. When a parameter
requesting an operation is used and the software is not
running, the operation is executed and the software
closes if it does not need user interaction.

Using a Project File
When the user programs different devices, it can happen
that the program is set up differently than expected.
Whenever it is possible , it is recommended to use
project files (.PPR) that hold all the program settings
needed for programming and paths to the data files.

Examples of Use
File Opening
up.exe project.ppr

up.exe "C:\My Documents\Recent Projects\PIC
\My latest project\project.ppr"

Device Programming
up.exe /p project.ppr

up.exe /p "C:\My Documents\Recent Projects\PIC
\My latest project\project.ppr"

5.6.2 Program Return
Codes

0 Problem-free execution.

1 File error. File not found or incorrect file
format, for example.

2 Equipment error. Communication test
failed, communication error.

3 Programming preparation error. device
cannot be erased, etc.

4 Programming error.

5 Verification error.

6 Programming failed due to a need to
communicate with user.

7 Device ID error.

8 Not supported.

9 Error of the serial number entered using the
/sn parameter.

10 Error, device protected.

0x10000 + const Revision of the device read using /
getpartrev parameter.

Note: The return value can be found in the %errorlevel%
variable if working with batch files.

5.6.3 Work flow monitoring
When the application was started in the quiet mode
(with /q parameter) on the commandline, an external
application can monitor its work flow by reading of the
value of the main ProgressBar, it is being continuously
saved to a Named Shared Memory.

The UP software shares a variable of size of one Integer. It
can be accessed using OpenFileMapping and
MapViewOfFile Windows functions. The name of the
shared variable is the UP window class name plus
_Progress string. E.g., when the name is set to up1 using
the /w parameter, then the name of the shared variable is
up1_Progress.
In the installation directory of the UP, in an
example_ProgressBar subdirectory, there is a C language
example of how to read the ProgressBar value.
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5.7 Running UP by Means
of Windows Messages
The UP program can be controlled by means of messages
of the Windows operating system. The running instance of
UP executes the requested command immediately after
message receipt.

Messages must be sent to "up v1.x" class window. The
message type is always of WM_USER.

Commands are identified by “wParam” while parameters
by “lParam”.

5.7.1 List of Commands
Unless specified otherwise, the command returns to its
return value:

0 error, failed

1 everything worked OK

Commands with a wParam of 1, 2, 3, 4, 5, 6, 7 and 24 are
thread blocking.

wParam lParam Description
0 0 does not performanything, returns 1

1 SetForegroundWindow()
2 Maximize, SetForegroundWindow()

1 any programs everything,same returncode as
fromthe command line

2 any programming excl.datamemory,same
returncode asfromthe command line

3 see
below

programming incl.erasing,same returncode
asfromthe command line

bit 0 =1 code/mainmemory
bit 1=1 datamemory (EEPROM)
bit 2 =1 configurationmemory
bit 3 =1 boot memory (MSP430,CC430)

4 see
below

reading

bit 0 =1 code/mainmemory
bit 1=1 datamemory (EEPROM)
bit 2 =1 configurationmemory
bit 3 =1 boot memory (MSP430,CC430)

5 see
below

differential programming

bit 0 =1 code/mainmemory
bit 1=1 datamemory (EEPROM)
bit 2 =1 configurationmemory

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om



Page 67

bit 3 = 1 boot memory (MSP430,CC430)
6 see

below
verification

bit 0 = 1 code/mainmemory
bit 1= 1 datamemory (EEPROM)
bit 2 = 1 configurationmemory
bit 3 = 1 boot memory (MSP430,CC430)

7 see
below

erasing, same returncode asfromthe
command line

bit 0 = 1 code/mainmemory
bit 1= 1 datamemory (EEPROM)
bit 3 = 1 boot memory (MSP430,CC430)

8 see
below

BlankCheckof memory,same returncode as
fromthe command line

bit 0 = 1 code/mainmemory
bit 1= 1 datamemory (EEPROM)
bit 2 = 1 configurationmemory
bit 3 = 1 boot memory (MSP430,CC430)

15 any pressestheGObutton, returns 1
16 see

below
asks if the programmersupportsthefunction

0 MCLRControl_Run
1 MCLRControl_Stop
2 MCLRControl_Reset
8 current voltage at pinVDD

17 see
below

performsthe programmerfunction

0 MCLRControl_Run
1 MCLRControl_Stop
2 MCLRControl_Reset
8 current voltage at pinVDD

return value PRESTO:
0 – unknown level
1 – 0V
2 – approx. 2V
3 – approx.5V

4 – morethan6V
return value FORTE:
-1-measuringerror
xx -measuredvoltage ×10
example: 33 means3.3V

24 address readsdatafromaddress, returnserrorcode,
data are returnedwithwParam=25

25 any returns last data readwithwParamof 24
32 see

below
UPprogram initialization

bit 0 = 1 reloadsettings(reloadproject/inifileor
registry)

bit 1= 1 reload languagefile
bit 2 = 1 recreate programmer(like programmerwas

changed)
bit 3 = 1 reload programmersettings(like port

settings)
bit 4 = 1 reload selecteddevice
bit 5 = 1 reloadcurrent file(.hex, .bin, ...)
bit 6 = 1 recreate alldialogwindows(adjust theirsize

when reloadingdevice)
0x 0100 refreshdevicespecificwindows
0x0200 refreshalleditors
0x 0300 refreshproject captions

33 1 save allproject settings
48 see

below1
saves current file(same asCtrl+S), returns0
when therewas no errorelse returns a
nonzerovalue

bit 0 = 1 code/mainmemory
bit 1= 1 datamemory (EEPROM)
bit 2 = 1 configurationmemory
bit 3 = 1 boot memory (MSP430,CC430)

56 0 returnsthe handle of the UPmainform

Table 9: Commands WM_USER

A message of the WM_CLOSE type closes the UP
program.
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Example of use
var

window: HWND;
begin

window := FindWindow('up v1 .x', nil);
Result := SendMessage(window,

WM_USER, 0, 0);
end.

1 Only parameter lParam=1 or lParam=2 are allowed for
AVR microcontrollers.

5.8 UP_DLL.DLL Library
Thanks to this library strings can be exchanged with the
UP program.

As the library needs to communicate with UP, the
program must be running. UP_DLL cannot work on its
own.
unit up_dll;
interface

Function UP_LoadFile (FileName: PChar; style: in
teger): integer; stdcall;
(*
* Load File (with extension .hex or .ppr);
* Loading of .ppr file can result in loading .he
x file too;
* Result codes are same like on command
* line .
*
* Style |
= 1; UP will be quiet on file load errors
* Style |
= 2; UP will do no previous file saving
*
*)

Function UP_GetStrValue(ValueName: PChar; Value:
PChar; Size: integer): integer; stdcall;

Function UP_GetIntValue(ValueName: PChar; var Va
lue: integer): LongBool; stdcall;

Function UP_SetStrValue(ValueName: PChar; Value:
PChar): LongBool; stdcall;

Function UP_SetIntValue(ValueName: PChar; Value:
integer): LongBool; stdcall;

Function UP_LoadFile_Wnd(WndClass:PChar; FileNam
e: PChar; style:integer):integer; stdcall;

Function UP_SetStrValue_Wnd(WndClass:PChar; Valu
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eName: PChar; Value:PChar): BOOL; stdcall;

Function UP_SetIntValue_Wnd(WndClass:PChar; Valu
eName: PChar; Value:integer): BOOL; stdcall;

Function UP_GetStrValue_Wnd(WndClass:PChar; Valu
eName: PChar; Value: PChar; Size: integer): inte
ger; stdcall;

Function UP_GetIntValue_Wnd(WndClass:PChar; Valu
eName: PChar; var Value: integer): LongBool; std
call;

(*
* All these functions are used for changing
* internal settings of UP in runtime .
* UP_GetIntValue, UP_SetStrValue,
* UP_SetIntValue returns nonzero if
* successful
* UP_GetStrValue returns amount of
* characters to copy into Value string
* including null terminator
* If Size is less than requied size, no
* characters are copied.
*)

Function UP_GetChecksum(Recalculate: integer; Ch
ecksum: PChar; Size: integer): BOOL; stdcall;

Function UP_GetChecksum_Wnd(WndClass:PChar; Reca
lculate: integer; Checksum: PChar; Size: integer
): BOOL; stdcall;

(*
* These functions return checksum value from the
UP, where:
* Recalculate = 0; only returns the checksum
* Recalculate = 1; checksum will be recalculated
first
* Checksum; the returned checksum as string
* Size; the length of the Checksum array, the ca
ller have to fill
* WndClass; the UP window class name
*)

implementation

function UP_LoadFile; external 'up_dll.dll';

function UP_GetStrValue; external 'up_dll.dll';

function UP_GetIntValue; external 'up_dll.dll';

function UP_SetStrValue; external 'up_dll.dll';

function UP_SetIntValue; external 'up_dll.dll';

function UP_LoadFile_Wnd; external 'up_dll.dll';

function UP_SetStrValue_Wnd; external 'up_dll .dl
l';

function UP_SetIntValue_Wnd; external 'up_dll .dl
l';

function UP_GetStrValue_Wnd; external 'up_dll .dl
l';
function UP_GetIntValue_Wnd; external 'up_dll .dl
l';

function UP_GetChecksum; external 'up_dll.dll';
function UP_GetChecksum_Wnd; external 'up_dll .dl
l';

end.

For further information see Appendix A UP_DLL.DLL.

5.9 Running More Than
One Instance of UP
If you need to connect more than one programmer to one
computer, a separate instance of UP must be running for
each programmer connected.
UP should be running in just one instance for standard
use. Each additional instance just sends commands from
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the command line to the already running first instance or
makes it visible in another way.

However, UP can be started and run in several instances if
used together with the parameter /w and a different
window class name. Those programs (instances) having
the same window class name will communicate with each
other.

Parameters for the program controlled from the command
line are described in Running UP from Command Line.

Example of use
The first instance of UP can be started the standard way
from the start menu.

Additional instances can be started from the command
line as up.exe /w "another up" , for example.

5.10 Access of More UP
Instances to One
Programmer
Only one program or utility can access one programmer
at any one time.

The operating system takes care of the access rights of
programmers connected to the USB interface.

If UP is running, the operating system does not allow any
other program to access the selected programmer as UP
needs to continually check the GO button state and the
voltage on the feeding pin.

UP can temporarily be prohibited to access the
programmer and the programmer freed this way for
another application. This can be done by choosing
Options → Select programmer . As long as this dialog is
open, another program can access the programmer. The
data the system works with in HEX editors does not get
lost by closing this dialog window.

5.11 Updating UP
If a newer program version is available on the web, it is
recommended to update the existing version as it may
eliminate known bugs or make the programming
algorithm for a particular device more efficient.

New versions also add newly supported types of devices.

Updates are free and are very easy. You can download a
new program version from https://www.asix.tech/
prg_up_en.html and simply install it over the previous one
by running the installer and clicking the Next button till it
finishes.

You do not have to worry about losing the settings you
created in your current program version. The installation
preserves all of them.

You can set an automatic check for newer versions on the
web in Options → Program settings → Others.

5.12 Appendix A UP_DLL.DLL
This appendix deals with the names of settings and
values of functions in the UP_DLL.DLL library.

Please look at the sample batch files in UP installation
folder for better understanding.

The following information is provided only for experienced
users and does not provide any guarantee.

5.12.1 Data Types
string is string

integer signed 32bit value

boolean accessed like integers; 0 is false, other
value is true
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5.12.2 List of UP variables
Prog.LoadFileBfgProg
boolean
If true, current file is reloaded before device (or its part) is
programmed.

Prog.LoadFileBfgProgWarnMod
boolean
If true, the program warns when it is set to reload current
file before programming and data in some editor have
been manually modified.

Prog.LoadFileBfgProgWarnOnNoChange
boolean
If true, the program warns when it is set to reload current
file before programming and the content of the loaded file
has not changed from the previous programming.

File.AutoCheck
boolean
If true, current file is periodically tested for changes.

File.LoadOnModify
boolean
If true, when change is detected, question pops up.

FileLoad.ClearData

FileLoad.ClearCfg

FileLoad.ClearID

FileLoad.ClearCode
boolean

If true, the contents of code memory is erased (in UP
memory) before new file is loaded;

all cells not stored in the file will have its default (blank)
state.

Part.Name
string
Selected device name

Prog.Name
string

Selected programmer name

Possible values are PREST, FORTE.

Prog.PortBase
integer

Serial number of programmer

Prog.UseOnlyThisSN
boolean
If true, the SN saved in the up.ini is always used regardles
of the SN contained in a project file.

LanguageFile
string

Relative path to used languange file

Project.File
string

Project file path

Project.Present
boolean

Project.Template
boolean
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If true, the user is asked for project name before its
saving.

HexFile.File
string
Opened current file path

HexFile.Present
boolean

HexFile.IHex
boolean
If true, the file with extension different from .HEX or .BIN
is loaded as HEX file.

HexFile.Template
boolean
If true, the user is asked for name before saving.

HexFile.SaveVoid
boolean
If true, empty cells are saved, too.

HexFile.AskForBinEndian
boolean
If true, the user is asked if the loaded BIN file should be
loaded as Little or Big endian.

HexFile.BinLittleEndian
boolean
If true, the loaded BIN file is loaded as Little endian.

HexFile.LoadDataAuto
boolean
If true, with file is loaded also a separate file for data
memory.

HexFile.LastDataFile

string

Path of a separate file for data memory.

HexFile.DataIHex
boolean
If true, the file for data memory with extension different
from .HEX or .BIN is loaded as HEX file.

Prog.QBfrEraseFlash
boolean
Question before erasing flash devices

Prog.QBfrProgFlash
boolean
Question before programming flash devices

Prog.QBfrProg
boolean
Question before programming OTP devices

Prog.QBfrDiffProg
boolean
Question before differential programming (of flash
devices)

Prog.QBfrProgCP
boolean
Warning before programming device with some kind of
protection

Prog.CloseStatOnGoodAct
boolean
If true, status window will be automatically closed after
read/verify etc... without errors.

Prog.CloseStatOnGoodProg
boolean
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If true, status window will be automatically closed after
programming without errors.

Prog.BeepOnGoodProg
boolean
If true, program makes a sound on successful
programming.

Prog.BeepOnBadProg
boolean
If true, program makes a sound on unsuccessful
programming.

Prog.SoundsOff
boolean
If true, all sounds of the program are switched off.

Prog.SkipBlankForCfg
boolean
If true, no blank check of part is performed before
programming of configuration space.

Prog.SkipBlankCheck
boolean
If true, no blank check of device is performed before
device programming.

Prog.SkipErase
boolean
If true, no erasing is performed before device
programming.

Prog.SkipEraseData
boolean
If true, no erasing is performed before only data memory
programming.

Prog.SkipLastFFVerify

boolean

If true, verification of empty FF positions at the end of the
programmed memory is not preformed.

Prog.SkipVerify
boolean
If true, no verification is performed after programming.

Prog.DoubleVerify
boolean
If true, verification on two supply voltages is performed
after programming. Supported by FORTE with internal
supply voltage only.

Prog.DoubleVerifyV1
integer

Defines supply voltage size for the first verification, the
value is in volts x 10.

Prog.DoubleVerifyV2
integer

Defines supply voltage size for the second verification,
the value is in volts x 10.

Serial
integer
0 no serial numbers

1 serial numbers are from external file

2 serial numbers are calculated

Serial.Step
integer

Step of serial numbers

Serial.File
string
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File name of external file with serial numbers

Serial.File.Next
string

Label of serial number

Serial.Length
integer

If serial number is computed, serial number length
(digits)

Serial.Actual
(unsigned) integer
If serial number is computed, actual computed serial
number (if decimal, coded as BCD)

Serial.ASCII
boolean
If serial number is computed, if true, serial number is
stored to device as ASCII characters.

Serial.SaveTo
integer
1 code/main memory

2 data memory

4 ID positions

Serial.Retlw
boolean
If serial number is computed, if true, memory cells are
filled with retlw instructions.

Serial.Addr
integer
If serial number is computed, address where to save

Serial.CPW
integer
If serial number is computed, chars per word

Serial.Base
integer
If serial number is computed, base of serial number, can
be only 10 or 16

Serial.Succ
integer
next serial number is

0 same

1 incremented

2 decremented

3 random (LSFR)

Serial.Order
integer
0 HiLo hilo

1 hilo HiLo

2 LoHi lohi

3 lohi LoHi

Serial.Write.BeforeProg
boolean
If true, current serial number is "written" into opened HEX
editors just before programming the device.

Serial.Write.AfterProg
boolean
If true, current serial number is "written" into opened HEX
editors after successful programming.
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Serial.Succ.AfterProg
boolean
If true, next serial number is generated after successful
programming.

Serial.LogSN
boolean
If true, the result of programming is logged to a selected
file.

Serial.LogFile
string

File name of a file where the result of the programming
will be logged.

ICSP.LongTime
boolean
If true, longer times for switching Vcc are taken.

ICSP.LongTime.Time.SwOn
integer

Time to wait after Vcc is switched on in microseconds.

ICSP.LongTime.Time.SwOff
integer

Time to wait after Vcc is switched off in microseconds.

SpecSettings.PREST.Power
integer

0 idle power supply is None / External

1 idle power supply is Internal 5 V

SpecSettings.PREST.ProgPower
integer

0 power supply during programming is
External 2.7 to 5.5 V

1 power supply during programming is
Internal 5 V

SpecSettings.PREST.i2cSpeed
integer

0 100 kHz

1 500 kHz

2 1 MHz

3 Maximal

SpecSettings.PREST.i2cAddr
integer
0 first suitable address or N/A

1 second suitable address
etc...

SpecSettings.PREST.LVP
integer
0 HVP method

1 LVP method

SpecSettings.PREST.PICAlg
integer
0 automatic selection

1 assume VDD = 5 V

2 assume VDD < 5 V

SpecSettings.PREST.UsePE
boolean
If true, PE (programming executive) is used for
programming of PIC MCUs.

SpecSettings.PREST.PIC32MZ_BootProg
integer
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0 Lower Boot alias

1 Boot Flash 1 and 2

SpecSettings.PREST.PSoCAlg
integer
0 automatic selection

1 assume VDD > 3.6 V

2 assume VDD =< 3.6 V

SpecSettings.PREST.PSoCRSTInit
integer
0 Reset mode

1 Power cycling

SpecSettings.PREST.MSP430osc
integer
0 Calibrated internal RC oscilator

1 Not calibrated internal RC oscilator

SpecSettings.PREST.MSP430speed
integer
0 Normal

1 Slow

2 Slowest

SpecSettings.PREST.MSP430EraseSegme
ntA
boolean

If true, MSP430 Segment A is erased.

SpecSettings.PREST.SPI_Flash_Freq
integer

0 3 MHz

1 1.5 MHz

2 750 kHz

SpecSettings.PREST.AVRXTAL.CLK

SpecSettings.PREST.AVRXTAL.RPT
integers

represent maximum AVR oscillator frequency

values can be found in *.lng files at item
MainForm.PRESTSpecForm.ComboAVRXTAL.xxx.Items
where xxx is minimum divisor of system clock of selected
AVR's SPI module. This is 2 for new AVRs, 3 and 4 for
older AVRs and 24 for Atmel's 8051 arch. processors.

These settings can be found in ini file too at
[SpecSettings.PREST], XTALRpt and XTALClk.

SpecSettings.PREST.AVRXTAL.AutoClk
boolean
If true, faster programming with slow clock is used for
AVR MCUs.

SpecSettings.PREST.AVRRSTInverse
boolean
If true, the reset signal polarity is assumed to be inverse
in comparison with standard polarity of the reset signal of
the selected chip. It is supported with AVR and 8051
devices.

SpecSettings.PREST.AVRHVP
boolean
If true, high voltage method is used for AVR MCUs, it is
supported for AVR TPI interface only.

SpecSettings.FORTE.UVCCLevel
integer
Defines the size of the internal supply voltage provided by
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FORTE programmer. The value is in volts x 10.

SpecSettings.FORTE.Power
boolean

If true, idle power supply is provided by FORTE
programmer.

SpecSettings.FORTE.ProgPower
boolean
If true, the supply voltage during programming is
provided by FORTE programmer.

SpecSettings.FORTE.LVP
integer
0 HVP method

1 LVP method

SpecSettings.FORTE.UsePE
boolean
If true, PE (programming executive) is used for
programming of PIC MCUs, when programmed by FORTE
programmer.

SpecSettings.FORTE.PIC32MZ_BootProg
integer

0 Lower Boot alias

1 Boot Flash 1 and 2

SpecSettings.FORTE.PSoCAlg
integer
0 automatic selection

1 assume VDD > 3.6 V

2 assume VDD =< 3.6 V

SpecSettings.FORTE.PSoCRSTInit
integer

0 Reset mode

1 Power cycling

SpecSettings.FORTE.MSP430osc
integer
0 Calibrated internal RC oscilator

1 Not calibrated internal RC oscilator

SpecSettings.FORTE.MSP430speed
integer
0 Normal

1 Slow

2 Slowest

SpecSettings.FORTE.MSP430EraseSegme
ntA
boolean

If true, MSP430 Segment A is erased.

SpecSettings.FORTE.MSP430Interface
integer

0 JTAG

1 SBW

SpecSettings.FORTE.ARMFreq
integer

The value specifies the frequency of connected oscillator
or crystal. This value is used for programming of
ARM7TDMI.

SpecSettings.FORTE.ARMOscType
integer

0 Crystal

1 Ext. Clock
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2 Int.RC 32 kHz

SpecSettings.FORTE.ARMCommFreq
integer

Selects communication frequency between FORTE
programmer and the programmed chip. The frequencies
are same as stated in the "Communication frequency"
ComboBox in UP. 0 means the highest frequency, 1 is
lower and so on.

SpecSettings.FORTE.SPI_Flash_Freq
integer

Selects communication frequency between FORTE
programmer and the programmed chip. The frequencies
are same as stated in the "Communication frequency"
ComboBox in UP. 0 means the highest frequency, 1 is
lower and so on.

SpecSettings.FORTE.AVRXTAL.DELAY
integer

represents maximum AVR oscillator frequency

value can be found in *.lng files at item
MainForm.PRESTSpecForm.ComboAVRXTALPresto2.xxx.It
ems where xxx is minimum divisor of system clock of
selected AVR's SPI module. This is 2 for new AVRs, 3 and
4 for older AVRs and 24 for Atmel's 8051 arch.
processors.
This setting can be found in ini file too at
[SpecSettings.FORTE], XTALClk.

SpecSettings.FORTE.AVRXTAL.AutoClk
boolean

If true, faster programming with slow clock is used for
AVR MCUs.

SpecSettings.FORTE.AVRRSTInverse
boolean
If true, the reset signal polarity is assumed to be inverse

in comparison with standard polarity of the reset signal of
the selected chip. It is supported with AVR and 8051
devices.

SpecSettings.FORTE.AVRHVP
boolean

If true, high voltage method is used for AVR MCUs, it is
supported for AVR TPI interface only.

SpecSettings.FORTE.ATxmegaInterface
integer

0 PDI

1 JTAG

SpecSettings.FORTE.i2cSpeed
integer

0 100 kHz

1 400 kHz

2 1 MHz

3 Maximal

SpecSettings.FORTE.i2cAddr
integer

0 first suitable address or N/A

1 second suitable address
etc...

5.13 Appendix B: Use of ICSP
ICSP (In-Circuit Serial Programming) is a method of PIC
microcontroller programming making it possible to
program devices already placed on PCBs.

Two different algorithms may be used for PIC
microcontroller programming: HVP (using programming
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voltage on pin -MCLR/VPP) or LVP (using the LVP pin).

The LVP programming algorithm can be disabled in the
device's configuration word. Microcontrollers have the
LVP algorithm enabled from the production, therefore
their PGM input needs to be treated during the first
programming (PGM input must be in log.0 for the time of
programming by means of the HVP algorithm).

Note: Not all devices have the PGM pin.

5.13.1 Pins Used for
Programming

This chapter describes how to treat pins in the ICSP
programming mode in accordance with the programming
algorithm.

HVP Algorithm
• PGM pin (if the device has one) must be maintained in
log. 0!!

• -MCLR/VPP must be separated from the resetting
circuits (with a 10 kΩ resistor, for example).
A programming voltage is supplied to this pin P(VPP)
for programming. The leading edge and the voltage
level at VPP must not be influenced by the application.
The PRESTO programmer supports only fixed voltage
of 13 V on pin P(VPP) in contrast to adjustable voltage
within a range of 6.5 V to 17 V supported by FORTE.
Please check limit voltage value on pin -MCLR/VPP of
the PIC device to be programmed by PRESTO.

• RB6 and RB7 pins must not be influenced by the
application during programming.

LVP algorithm (without VPP)
• RB6, RB7, PGM and -MCLR/VPP pins must not be
influenced by the application during programming. All
pins are in various logical levels during programming.

Loading of Different
Programmer Pins
The maximum current drawn from I/O pins, from pins
P(VPP) and VDD can be found in the Technical
Specification.

OTP (One-Time Programmable) devices have a
considerably higher current consumption on pin P(VPP)
than devices with a FLASH memory. Therefore the
application should not have any additional current
consumption at pin P(VPP) in case of OTP.

Data pins may have their signals changing at a speed of
several MHz, so the application must not influence the
signals in any significant way.

5.13.2 Power Supply Options
Connecting the shared data and power supply ground
(GND) is obviously necessary for all cases. The
microcontroller being programmed can be fed:

• externally from an application
• internally from a programmer
The external power supply from the application cannot be
used for some types of microcontroller having the -MCLR/
VPP pin alternatively configurable as an I/O.

The internal power supply can be used only in cases
where the application does not draw too much current
from programmer's feeding pin (VDD). The maximum
allowed current consumption can be found in the
Technical Specification.

Both PRESTO and FORTE programmers feature an
overcurrent protection. PRESTO has a software protection
in which an output gets disconnected by the running UP
program having detected an overload. FORTE has a
hardware protection, which does not depend on the
control software.
The programmer switches the power supply off if the

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om



Page 80

maximum load is substantially exceeded for a certain
time (this time is adjustable). PRESTO checks for the
overload state the whole time the power supply is
connected.

Support for an external power supply is integrated in both
PRESTO and FORTE hardware. The programmer feeds the
input and output circuits with a voltage connected to pin
VDD. The voltage may be lower than 5 V.

Advice
Whendesigningthe process, please pay specialattention
tothetypeof devicetobe programmed – if it can be not
only operated but also programmedat avoltage lower
than5V.

Power Supply Capacities in
Application
If there are capacities present at the application's power-
supply pin that would slow down the power on/off
switching and application is fed from programmer during
programming, longer charging/discharging times need to
be set in UP. In other case UP will probably announce
overcurrent on VDD pin.

An approximate time that should be set in the program:

t[μs] = 2.5 × C[μF] × R[Ω].
The equivalent resistance is presented in table following
table:

Programmer Charging current Discharging current
PRESTO Correspondsto 50Ω Correspondsto 1kΩ
FORTE Correspondsto 50Ω Correspondsto 27Ω

Table 10: Equivalent resistance of pin VDD

Example

The necessary charging time for an application with
a 33 μF capacitor programmed with PRESTO:

2.5 × 33 × 50 = 4125 μs
discharging:

2.5 × 33 × 1000 = 82.5 ms.

For further information on the setting see r Delay for VDD
switching on/off when supplied from programmer.
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Notes

• An error may occur if UP cannot program the
calibration word or if a fault occurs during Device ID
reading, UP warns about an overcurrent at VDD, etc.
This may be eliminated by prolonging the charging/
discharging time in the r Delay for VDD switching on/
off when supplied from programmer option - up to
several seconds.

• If UP points out an overcurrent error at VPP, a shorter
ICSP cable may help (its maximum length is 15 cm).

5.13.3 ICSP Connector
All ASIX programmers use a unified connector with
2.54 mm spacing of pins for programming with the ICSP
algorithm.

This connector has 8 pins with 7 signals. Not all signals
are always needed for the programming itself.

For further information on connecting a device to the
programmer see Connection Examples.

Pin No. Signal Programming connector

1 -MCLR P/ VPP
2 not used(key)
3 VCC VDD
4 GND GND
5 RB7 D/ DATA
6 RB6 C/ CLOCK
7 not used
8 RB3/RB4/RB5 L/ LVP

Table 11: ICSP connector

The following drawing illustrates the recommended
connection of -MCLR/VPP pin found in Microchip
microcontrollers for device programming through the
ICSP interface.

Fig. 26: Recommended connection of -MCLR/VPP pin

5.14 Appendix C: Intel-HEX
File Format
This appendix describes the format of Intel-HEX files used
by UP for data reading and saving. .hex is the typical
extension for such a file.

5.14.1 Supported
Alternatives of HEX
Files

UP supports 2 basic alternatives of Intel-HEX files:

• "basic", sometimes also 8-bit Intel-HEX File (e.g.
Microchip MPASMWIN generates this file with
parameter INHX8M).

• "extended", sometimes also 32-bit Intel-HEX File (e.g.
Microchip MPASMWIN generates this file with
parameter INHX32).
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5.14.2 Description of
Intel-HEX File Format

Intel-HEX are text files consisting of lines.

Each line has the following structure:

:LLAAAATTDDDD. . .CC

„:“ Each line in a file must start with this
character (colon, 0x3A).

LL Length of record (number of DD fields).

AAAA Address of record's first byte.

TT Record type. The types may be:

00 - Data

01 - End of file. Each file must finish with
this record.

02 - Extended segment address. (32-bit
Intel-HEX only)

04 - Extended linear address. (32-bit
Intel-HEX only)

There are also other types like 03 and 05, which are
ignored by UP while reading and not used for saving.

DD Record data. The number of bytes must be
exactly LL.

CC Checksum. The check sum is computed as
a binary supplement to the sum of all
values on the line.

Data Record
A line with the configuration memory of a 14-bit device is
used here as an example.

:02400E00413F30

02 Record length. The configuration memory
size is one word = 14 bit = 2 byte (byte
alignment).

400E Record address. The configuration memory
address is the word 2007h addressed by
bytes, i.e. 400Eh.

00 Record type = data

413 F Record data. Configuration word =3F41h

30 Check sum. 30 = 02 + 40 + 0E + 00 + 41
+ 3F = xxD0; neg D0 = 30

End of File
The only acceptable alternative of the End of file line is:

:00000001FF

Extended Linear Address
Only files that need to address more than 64 kB of the
addressed space contain this line.

For example, processors of the PIC18F family have their
configuration memory saved at the address 0x 30 00 00
00.

If this address needs to be used, it is necessary to insert a
line in the .hex file specifying the extended linear
address, i.e. the upper 16 bites of the address. The lower
16 bits are read from the line with the data record.

:020000040030CA

This line selects the configuration memory of PIC18F
family devices.

The extended segment records specify the segment, i.e.
bits 19-4 of the address, which are then added to
addresses from the data records (offset).
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Saving Device Type in .hex File
Users frequently mistook the selected device type for the
device type for which the .hex file was saved. To
eliminate this, UP contains a function allowing you to save
the device type in a file.

The program adds one more line below the End of File:
#PART=.... The absolute majority of programs working
with Intel-HEX files ignore this line, but such a modified
file cannot be considered as complying with the Intel-HEX
format.
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6

up_control.dll library
The up_control.dll enables user to control the UP software
using functions contained in the library. It contains basic
programming functions.

From the view of the user the UP software is running
invisibly.

There is more information concerning the library available
in a separate document.
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7

PRESTO.DLL Library
The presto.dll library has been designed for working
together with the PRESTO programmer.

The implemented functions allow you to set logical levels
at different programmer's pins as needed or to read their
state. Various communication protocols can be created
thanks to this.

The function QsetPins() is provided for controlling all
pins that can work as an output, while the function
QGetPins() serves for reading pins working as an input.

The function QSendByte() allows you to quickly send an
SPI Byte to data and clock pins. If reading is needed at
the same time, use the QsendByte_OutIn() function.

In addition there are functions for setting the
programmer's characteristics, controlling the voltage or
reading the return values.

This library can be used with all revisions of the PRESTO
programmer regardless of the hardware version.

The functions implemented in the presto.dll library are
described in detail in a separate document devoted to
this library.
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8

JTAG PLAYER
JTAG PLAYER is a utility designed for programming
devices with the JTAG interface by means of PRESTO or
FORTE programmers.

This utility is not part of the UP software installation pack
but it can be downloaded separately from https://
www.asix.tech/prg_jtag-svf-player_cz.html

JTAG PLAYER is localized only in English.

8.1 JTAG Device
Programming
Having started JTAG PLAYER, select your programmer in
Opt ions → Select Programmer .

If you cannot see your connected programmer in the
dialog window, check if the green ON-LINE LED on the
programmer is on. If so, make sure thatanother software
is not communicating with the programmer.

Program the device by choosing File → Open&Process.
The file to be programmed must be in SVF/XSVF format.
For more information on the file format see SVF File or
XSVF File.
If an error occurs during the programming process, check
the connection between the programmer and the
application. In addition, check the presence of a feeding
voltage.

Important warning
A powersupply voltagefromanexternalsourcemust be
present during programmingthat utilizestheJTAG
interface.The programmerdoes not feedtheapplication
inthis case.

8.1.1 SVF File
SVF (Serial Vector Format) is a file used for describing
high- level operations on the IEEE 1149.1 bus.

Serial Vector Format ( .svf) is the recommended file
format for al l the test ing and programming except
for Xi l inx CPLD XC9500. The Xil inx Serial Vector
Format (.xsvf) is recommended for Xilinx CPLDXC9500.

Examples of How to Create SVF
Files
This chapter presents methods of creating an SVF file for
different types of device.

Atmel AVR (e.g. ATmega128)
Programming
Generate an SVF file using the avrsvf.exe program
available at the ATMEL website in the “Tools & Software
of AVR 8-bit RISC MCUs” section.
Example:

avrsvf -datmega128 -s -e -ifmyfile.hex -pf -vf -
ovmyfile .svf -mp

This example shows how to create an SVF file from the
myfile.hex file. The final SVF file is then used by
jtagplay.exe for erasing, programming and verification.
Run avrsvf -h for more information.

The device must be in the reset state during
programming.
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Notes

Some AVR devices do not support page by page
programming. In such a case, the SVF file must be
created without the -mp parameter.

Lattice CPLD Programming
SVF file can be created from a .JED file using ispVM
System. This program is part of the ispLEVER Classic
system, which is available at the Lattice website.

Altera CPLD Programming
The QUARTUS II program by Altera can generate SVF files
if it is set up so in the menu.

Such an SVF file, however, cannot be used as it is due to
a wrong Silicon ID. According to Altera, SVF files
generated by their software are assumed only for ATE
(Automatic Test Equipment) programmers and Altera
does not consider supporting others.

However, such an SVF file can be manually modified to
suit our needs. In order to do so, delete the "CHECKING
SILICON ID" section in the SVF file or mark it as a non-
executable comment.

State of .svf File
Implementation
The SVF file support has been implemented in accordance
with the "Serial Vector Format Specification, Revision E"
available at www.asset-intertech.com/support/svf.html
with the following limitations:

• PIO a PIOMAP commands are not implemented.
• HDR+SDR+TDR / HIR+SIR+TIR length is limited to
2^31 bits.

• Supported TCK frequencies are 3 MHz, 1.5 MHz,
750 kHz and fragments of 1 MHz starting at 500 kHz
for PRESTO. FORTE adds 15 MHz, 10 MHz and 5 MHz
on top of these.

• RUNTEST MAXIMUM max_time SEC parameter is
ignored.

• RUNTEST run_count is limited to 2^31/3
(approximately 715 million).

• RUNTEST min_time SEC is limited to 2^31/3 ms
(approximately 715 seconds).

• TRST and RUNTEST SCK – these commands share the
same configurable P/VPP pin of both the PRESTO and
FORTE programmers and can never be used together.

8.1.2 XSVF File
XSVF (Xilinx Serial Vector Format) is a file used for
describing high-level operations on the IEEE 1149.1 bus
extended by Xilinx.

XSVF is recommended for Xilinx CPLD XC9500.

Examples of How to Create
XSVF Files
Xilinx CPLD Programming
To create an XSVF file, use the iMPACT program available
at the Xilinx website.

Choose Prepare Configurat ion Files → Boundary-
Scan File → XSVF File in the Operation Mode
Selection dialog window that opens after the iMPACT
program starts. Run all operations (Erase, Program,
Verify, Test...) the same way as if a programmer was
connected (e.g. Xilinx Parallel Cable). Then save the new
file and close iMPACT. Running the created XSVF file will
perform the recorded operations.

We do not recommend using an SVF file for
programming devices of the Xilinx XC9500 family, as the
algorithm for XC9500/XL/XV device programming cannot
be correctly described in the SVF format.
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State of XSVF File
Implementation
The XSVF file support has been implemented in
accordance with the "XAPP503, Appendix B: XSVF File
Format" specification available at the Xilinx website with
the following limitations:

• XSETSDRMASKS, XSDRINC and XSIR2 commands are
not implemented.

• Only the XSVF file format is recommended for
programming the Xilinx XC9500/XV/XL families.

We seriously recommend using an SVF file for all
architectures except XC9500/XV/XL. For XC9500/XV/XL
programming, the use of the XSVF format is
recommended as the SVF format does not include the
XREPEAT command, which is necessary for XC9500/XV/XL
programming.

Warning: Executing a file containing the XREPEAT
command may be very slow.

8.1.3 Programming
Connector

The following table describes the functions of PRESTO's
and FORTE's pins for programming by means of the JTAG
interface.

PRESTO FORTE Function
VPP P SCK(SystemClock)/Userdefined state

duringfile executionandafter.
- - Not connected pin(key)
VDD VDD Feeding of I/Obuffers
GND GND Groundof I/Obuffers
MOSI D JTAGTDI(Test Data In)
CLOCK C JTAGTCK(Test Clock)
MISO I JTAGTDO(Test Data out)
LVP L JTAGTMS(Test Machine State)

Table 12:J TAG programming connector

8.2 Settings
This chapter explains the meaning of different settings in
Options → Program Options .

8.2.1 Default TCK signal
frequency

This frequency of the TCK clock is used until the JTAG
Player reaches the first FREQUENCY command in the SVF
file or until the FREQUENCY with the "default" value is
reached.
The XSVF file format does not support the FREQUENCY
default command. Therefore frequency defined by
Default TCK Signal Frequency parameter is applied to
all operations.
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The maximum frequency is 3 MHz for the PRESTO
programmer and 15 MHz for FORTE.

If the Ignore FREQUENCY commands option is selected,
the programmer applies only the frequency set by the
user and ignores all FREQUENCY commands.

8.2.2 Fast Clocks Option
(FORTE only)

This option is available only for the FORTE programmer.

According to the JTAG specification, the signal at TDI is
sampled at TCK's rising edge. However, should a higher
frequency be required (around 5 MHz or more), it may be
useful to change the moment of sampling from the rising
edge to the falling edge by shifting it by 1/2 of the TCK
period. To do so, choose Fast Clock Option .

8.2.3 RUNTEST without
run_count (SVF only)

The programmer should stay in the specified state for the
specified time and generate the clock signal on TCK while
executing an SVF file.

The specified time can be exceeded, but it slows the
programming process down. Even though it is not
supported by the SVF specification, many programmable
devices allow stopping the TCK clock during this time.

The programmer's ability to keep accurate time needs to
be considered. A high level of accuracy cannot be
achieved if the maximum frequency is used (the
programmer can guarantee respecting the min_time SEC
parameter only). A higher accuracy can be achieved with
slow clock (~100 kHz). If the clock signal is not used at
all, the programmer is capable of following the min_time
SEC parameter almost exactly.

Three possibilities are available considering these facts:

• no clock on TCK

• slow clock on TCK (~100 kHz)
• default speed clock on TCK
Example: "RUNTEST 3E-3 SEC;" means "Generate clock on
TCK for at least 3 ms".

8.2.4 RUNTEST Timing
Multiply (both SVF
and XSVF)

Recommended values:

• for accurate timing specified in the SVF or XSVF file:
0% (no added time)

• for XC9500(XL) family: 100% or more
• for Atmel AVR (e .g. ATmega128) : 25%

8.2.5 RUNTEST with
run count and no
timing
(both SVF and XSVF)

This command should be interpreted as the minimum
frequency on TCK.

Yet some SVF file generators (such as Xilinx iMPACT, for
example) use this command as waiting time and assume
a frequency of 1 MHz. For such cases the use of "interpret
as RUNTEST min_time with scale 1 MHz" setting is
recommended.

JTAG Player Behavior When Reaching RUNTIME
Command With MINTIME Specif icat ion

(This concerns only SVF files as the RUNTEST alternative,
which is usable in XSVF XRUNTEST run_count cannot
specify time.)
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• The RUNTEST command containing run_count and
specifying min_time is executed at the currently
running TCK frequency. Therefore the command can
take much more time than what is specified in
min_time.

• The RUNTEST command containing run_count and
specifying max_time is executed at the currently
running TCK frequency. As the programmer cannot
respect the “deadline” specified in the max_time
parameter, this parameter is ignored.

8.2.6 VPP PRESTO / P
FORTE pin usage
while running test
(file) / after test
completion

The selection of the VPP / P pin function: TRST or SCK as
described in the SVF file or user-defined output levels.
(This is useful to keep the device in the reset state during
file execution.)

8.2.7 Default Settings
The JTAG Player features several default settings intended
primarily for use in connection with FORTE, but not with
PRESTO. Feel free to change these settings if the default
values do not suit your application.

Default Settings for FPGAs
Default TCK frequency: 15 MHz; Ignore FREQUENCY
commands

Fast Clock Option (FORTE only): 5 MHz and above

RUNTEST without run_count (SVF only): default
speed clock on TCK

RUNTEST timing mul t iply (both SVF and XSVF): 0%

RUNTEST with run_count and no timing (both SVF
and XSVF): interpret as RUNTEST min_time with scale
1 MHz

VPP PRESTO / P FORTE pin usage whi le running test
(file): Tristate

VPP PRESTO / P FORTE pin usage after test
completion: Tristate

Default Settings for XC9500
Default TCK frequency: 5 MHz; Ignore FREQUENCY
commands

Fast Clock Option (FORTE only): 5 MHz and above

RUNTEST without run_count (SVF only): slow clock
on TCK (~100 kHz)

RUNTEST timing mul t ip ly (both SVF and XSVF):
100%

RUNTEST with run_count and no timing (both SVF
and XSVF): interpret as RUNTEST min_time with scale
1 MHz

VPP PRESTO / P FORTE pin usage whi le running test
(file): Tristate

VPP PRESTO / P FORTE pin usage after test
completion: Tristate

Default Settings for AVR:
Default TCK frequency: 1 MHz; Ignore FREQUENCY
commands

Fast Clock Option (FORTE only): 5 MHz and above

RUNTEST without run_count (SVF only): default
speed clock on TCK
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RUNTEST timing mul t ip ly (both SVF and XSVF):
25%

RUNTEST with run_count and no timing (both SVF
and XSVF): interpret as RUNTEST min_time with scale
1 MHz

VPP PRESTO / P FORTE pin usage whi le running test
(file): Tristate

VPP PRESTO / P FORTE pin usage after test
completion: Tristate

8.3 Running JTAG Player
from Command Line
SVF & XSVF JTAG Player can be run from the command
line for more comfort especially during debugging. The
following parameters apply:

jtagplay.exe [-p] [-f filename] [-i inifile] [-
c] [-cc] [-s serial]

-p automatically executes the file specified in
the -f filename parameter

-f filename specifies SVF / XSVF file to be executed

-i inifile ini file containing settings

-c closes the program if the file has been
executed without errors

-cc closes the program even if the file has been
executed with error(s)

-s serial uses PRESTO or FORTE programmer of the
specified serial number, when instead of
the serial number there is the "-" (dash)
sign, it will use any connected programmer
regardless of its serial number

-forte uses FORTE, not PRESTO

Return Codes

The jtagplay.exe program returns the following return
codes:

0 execution of the last file had no errors

1 an error occurred during execution of the
last file

2 execution of the last file could not be
started
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9

MultiUP
MultiUP is utility usable for programming with up to 4
ASIX programmers at once. MultiUP uses program UP.

The utility is installed together with the UP program.

MultiUP can simply, using one button, run programming
of selected task, which is deffined with the UP program
project and other settings.

To increase speed the utility loads the programming data
only once, it is suitable for using in production.

9.1 Programming settings
In the "Options/Programming settings" it is possible to
select programmers to be used, UP program project to be
programmed, whether they will program the common
way or using the differential programming and the
memories to be programmed.

To improve clarity it is possible to select a name for each
of the programmers.

Each of the programmers can program a different project
or all of them can be the same project.

All of the programmers do not have to be of the same
type (PRESTO, FORTE), but the selected project have to
use the same type of the programmer.

In the Options it is also possible to select Keyboard
shortcuts for running work of the praticular programmers
and to set the console saving during the program closing.
The parameters configured in the Options can be used
once or they can be saved to MPPR file for other using.

9.2 Programming
For programming of predefined tasks it is advisable to
open MultiUP project file in menu "File/Open MPPR file".
The project can be crated in the "Options" menu.

Afterwards the particular programmings can be run
separately using the "Run" button on the appropriate
programmer panel or all the active programmings can be
run at once using the "Run all" button, eventually the
associated keyboard shortcuts can be used.

9.3 CommandLine
It is possible to provide the MPPR project path on the
commandline, it will be loaded on the utility start.

Example:

multiup.exe C:\data\project.mppr
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10

TROUBLE-SHOOTING
This chapter describes how to proceed if experiencing
difficulties with device programming. It also describes
testing utilities for PRESTO and FORTE programmers
designed to check if the programmer is in good condition
or damaged. Please go through all the tips and tricks
before you send your programmer to a service shop.

The testing utilities are not part of the UP software
installation, but they can be downloaded separately from
https://www.asix.tech/prg_testers_en.html.

10.1 Tips and Tricks
Should you experience difficulties with programming, we
recommend checking the following points:

• Check the microcontroller and programmer
connections according to the description in Connecting
to Application. Even though it may seem trivial, it is
recommended to check the connection twice and to
assume the second time that the link does not always
lead where you want it to or it leads to more than one
point.

• If a crystal or other auxiliary devices are used for
programming, (typically pull-down or pull-up resistors),
check if their values and connections are correct.

• It is advisable (and often necessary) to have blocking
capacitors at the power supply of the device to be
programmed.

• If the device to be programmed has more than one
power-supplying pin, all of them must be really fed. It
is often recommended to check their voltage with a
voltmeter.

• Use of the latest version of UP is recommended. If you
are still using an older version, an update is
recommended.

• Are you programming a new device or has it been
previously programmed? If so, the problems may be
caused by unsuitably set fuses in the device.

• The length of the ICSP cable should not exceed 15 cm.
• Make sure that there is no additional capacity present
at the programming (data) pins. Consider if circuits on
the programming pins could cause too large a load for
programming.

• It is important that the crystal or the communication
speed settings reflect the reality in devices that need
that settings.

• Some devices may be programmed using several
different methods. Programming problems may be
caused by selecting a different programming interface
or a different programming mode than the ones that
the application is prepared for.

If none of the above tips help to eliminate the problem
and if it absolutely sure that the device to be
programmed is not faulty, the fault may lie in the
programmer.

To easily find out whether the programmer is in order or
not, you can use the testing utilities described in the
following chapters.

10.2 PRESTO Tester
he PRESTO Tester utility easily tests the “health
state” (usability) of the PRESTO programmer right at the
customer's site.

In order to run it successfully, only one PRESTO
programmer may be connected to the control PC and its
drivers must be correctly installed. This is confirmed by
the green LED being on.
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Fig. 27: Tester PRESTO

quality using a voltmeter. At the same time, the input
pins (pins P, D, I and L) indicate what logical level is
currently seen by the programmer.

In addition, a pull-up resistor may be connected to pin D.
This means that if its output is in the Tristate mode, pin D
starts reading log. 1.

The programming voltage of 13 V can be connected to
the output of pin P.

If everything seems to be in order, but the device still fails
to get programmed, it is recommended to check the
application connection according to instructions for
connecting a microcontroller to the programmer.

If in doubt as to whether the programmer is in order or
faulty, do not hesitate to contact our technical support.

After you start the tester, make sure that the
programmer's output buffers are fed. You can either use
the 5V from USB option or connect an external power-
supply voltage to the VDD pin. The level of detected
voltage is displayed in the lower part of the VDD&AUX
panel.

Basic communication with the programmer can easily be
recognized by the Active diode being on. You can also
use the Test → USB Flood Test menu option, which
tests the USB communication with the programmer in
both directions.

The programmer's serial number is displayed in the
window title bar. This number is necessary for any
communication with the service shop. You can also find
this number on the bar code label attached to the
programmer bottom.
Now you can switch logical levels for individual output
pins (pins P, D, D and L) and check the output signal
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HPR3V3
HPR3V3 is an optional accessory to the PRESTO
programmer for programming of stand-alone 3.3 V
devices as for example DataFlash Memories. The PRESTO
programmer can supply a programmed device with 5 V.
However, some devices require 3.3 V supply voltage and
3.3 V logic levels on their pins. In such case, the HPR3V3
level shifter or an external 3.3 V power supply have to be
used.

11.1 Usage
Plug the HPR3V3 level shifter directly to the pins of the
PRESTO programmer (NOT to the programmed device
connector!). Pin 2 is used as a key, so that it is not
possible to connect it wrong way. Now, connect the
programmed device to HPR3V3 using ICSP cable.
Connection of the programmed device pins is the same as
connection of the device to PRESTO.

Common connection diagram is below.

Fig. 28: Use of HPR3V3

Set internal power supply for programming.

Important warnings
The HPR3V3pinsare unidirectional,sothis
level shiftercan be usedfordeviceswith
unidirectionsignals likeSPIFlashmemories,
AVRdevices orMSP430deviceswithout SBW
interface, but it cannot be usedfor PIC
devices orMSP430deviceswith SBW
interface.

Never connect an external voltage to the
output 3.3 V supply pins!

11.2 HPR3V3 schematics

Fig. 29 : HPR3V3 schematics

11.3 Technical specification
min. typ. max.

VCCoutput supplyvoltage 3.2 3.3 3.37 V
ICCoutput supply current 90 mA
VOH output pinvoltage log.1 2.9 V
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VOLoutput pinvoltage log.0(25 °C) 0.36 V
IOUToutput pincurrent 4 mA

Table 13: Technical specification

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om

深
圳
市
益
芯
科
技
有
限
公
司

ww
w.
yx
m
icr
o.c
om



Page 97

12

HPR1V2
HPR1V2 is an optional accessory to the PRESTO
programmer for programming of the devices with supply
voltage and logical levels between 1.2 V and 3.3 V as for
example Xilinx CoolRunner-II .

The PRESTO programmer can program devices with signal
levels between 3 and 5 V ± 10%, but sometimes it is
necessary to program a device with less signal levels. In
such case, the HPR1V2 level shifter have to be used. The
level shifter have to be used with external supply voltage
from application, it cannot be supplied from the
programmer.

12.1 Usage
Plug the HPR1V2 level shifter directly to the pins of the
PRESTO programmer (NOT to the programmed device
connector!). Pin2 is used as a key, so that it is not
possible to connect it a wrong way. Now, connect the
programmed device to HPR1V2 using ICSP cable.
Connection of the programmed device pins is the same as
connection of the device to the PRESTO. Common
connection diagram is below.

Fig. 30: Use of HPR1V2

Important warning
The HPR1V2pinsare unidirectional,this level
shiftercan be usedforexamplewithJTAG
devices, but it cannot be usedwithdevices
that have save bidirectionalsignalsonthe
programming interface, like PIC
microcontrollers.

The HPR1V2 haveto be suppliedwithexternal
supply voltagefromapplication.

Neverturn on the internal supply voltage
from the programmer, when the HPR1V2 is
connected!
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12.2 HPR1V2 schematics

Fig. 31 : HPR1V2 schematics

12.3 Technical specification
min. max.

VCC supply voltage 1.2 3.3 V
VIH input pinvoltage log.1 0.65xVCC V
VIL input pinvoltage log.0 0.35xVCC V
IOUToutput pincurrent 4 mA

Table 14: Technical specification
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13

HPRAVR
HPRAVR is an optional accessory for PRESTO and FORTE
programmers for programming AVR microcontrollers in
applications with the ISP10PIN standard connector on the
device's side and with the ICSPCAB8 cable on the
programmer's side. The ISP10PIN connector is typically
used on boards with microcontrollers of the AVR type
such as STK500, for example.

13.1 Usage
Connect the HPRAVR adapter to the application's
connector. Make sure that pin 1 of the HPRAVR adapter is
connected to pin 1 of the ISP10PIN connector in the
application (Pin 1 is marked with a red dot at HPRAVR
while it may be marked in different ways on the
connected application – see information in the
corresponding manual).

Now interconnect the adapter and FORTE with an ICSP
cable. Pin 2 in the cable is used as the key. The following
picture illustrates a typical interconnection of the PRESTO
programmer with an application through the HPRAVR
adapter:

Fig. 32: Use of HPRAVR

ImportantWarning
PinNo. 1ofthe HPRAVRadapter is marked
with red color. Pleasedouble checkthe
positionof the pinNo.1 intheapplicationas
the applicationcould bedamaged if
incorrectly connected.

Fig. 33: ISP10PIN, top
view

Fig. 34: HPRAVR adapter diagram
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Fixed links.
2015-11-19 Addeddescriptionof setting oftheT pinduring and

after programming.
2016-01-22 Theserialnumbers loggingdescriptionhas been

updated.
2016-03-08 Addeddescriptionof the Display programmerform

function.
Addeddescriptionof the settingwhichdisablesthe
VPPbeforeVCCwarning.

2016-05-20 The PEdescriptionhas beenupdated.
Addeddescriptionof the start andendaddressfor
theSPI Flashmemories.

2016-10-10 Addeddescriptionof the/sncommandline
parameterand manualserial numbersdescription.
Addedthe commandline errorcode9description.

2016-12-15 Descriptionof usageof the programmersat Linux
has beenadded.

2017-02-02 Added atablewith recommendedvaluesof Rsfor
ZDs,under PICconnectionspicture.
Addeddescriptionof auto programming intheMass
productionwindow.
Addeddescriptionof Keepmanually modifieddata.

2017-02-10 The Linuxdriver instalationchapterhas been
completed.

2017-03-13 A linkto lin_ftd2xx hasbeenadded.
2017-03-23 Addeddescriptionof/q1commandline parameter.
2017-05-09 Addeddescriptionof "Load last project onstart-up"

option.
2017-06-29 Added chapterabout MultiUPutility.
2017-10-30 Addeddescriptionof "WhenusingWindows

Messagesdisableotherwarnings"option.
Addeddescriptionof "Write checksumto logfile"
option.

2018-02-19 The HPRchapters have beencompleted and
moved.

2018-03-28 Addeddescriptionof "Device info"menu item.
2018-05-17 Addeddescriptionof Renesas RX600settings.

Document
revision

Modificationsmade

2013-07-03 Newly created document
2013-12-18 Minortext corrections
2014-02-28 New command line parameter[/read]
2014-07-01 CEcertificatewas replaced by Declarationof

Conformity.
2014-09-23 Fixed I2Cmemoryexample picture.

Described newoption-Showonly the lowest byteof
word inASCII

2014-11-21 Updated list ofvariablesforup_dll.dll
2014-11-25 New settingsofthe UPprogramhave beenadded.
2015-02-03 AddedView/Console menudescription.

Addeddescriptionof PIC32MZ_BootProgvariable.
Smalltext fixes.

2015-03-12 The nameof itemDelay forVDDswitchingon/off
has beenchanged
Addeddescriptionof the checksumsettings

2015-04-07 Updated descriptionhow to createSVFfilefor
Lattice.

2015-05-19 Definitionof input voltageonpinswasadded.
Descriptionofw=32parameterforWindows
messageswas added.

2015-08-05 Descriptionof the programmerdriver installation
has beenchanged.
Added new/getpartrev parameter.
Added new commandlineerrorcodes.

2015-09-21 Addeddescriptionof the settingof thewarning
whenthe loadedfile isnot alignedtoaword size.
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Document history
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2018-07-30 Added a noteto Debugfuse of MCUPIC.
2018-08-10 Addeddescriptionwhere Linux FTDIdrivercanbe

found.
Added a noteto commandline parameters.

2019-01-25 Descriptionof savingfusesto inifunctionhas been
added.
Write RCoscAdjustment functiondescriptionhas
beenadded.

2019-01-31 Added descriptionof howto readthe ProgressBar
value inthequiet mode.

2019-02-26 Added descriptionof Readaddressfunction
AddeddescriptionofWindowsMessageswParamof
24 and25.

2019-04-23 Addeddescriptionof/df parameter,descriptionof/p
and/o parameters has beenupdated.

2019-06-26 Updateddescriptionof/s commandline parameter.
Addeddescriptionof "Lockproject"function.
Addeddescriptionof functionsetting actualSNfrom
logfile.

2019-09-20 Company address has beenchanged.
2019-10-24 Addedchapterabout up_control.dll
2020-01-10 AddedAutoload next filefunctiondescription.
2020-03-31 Addeddescriptionof /conf parameter.

Added list of parameterswhicharetransferredto
already running UPinstance.
Addeddescriptionof thefile locationsonly
programming.
Addeddescriptionof theoptionswitchingoff the
Device IDcheck.

2020-05-26 Addeddescriptionof "Load project unlocked"
function.
Addeddescriptionof howto use project onthe
commandline.

2021-01-11 Driver installationdescriptionhasbeenupdated.
UP software installationdescriptionhasbeen
updated.

JTAG Player-s parameterdescriptionhas been
updated.

2021-02-25 FixedWindowsMessagew=48description.
FixedWindows Messagestable.
Added adescriptionof a Recently useddevices list.

2022-01-07 Rulessettingswerechangedfor Linux installation.
2022-01-14 Descriptionof comments inserialnumbersfiles has

beenextended.
2022-06-28 Projectsdescriptionat commandlinechapterhas

beenmodified.
2023-01-12 The chapterabout CEandRoHS has beenmodified.

Added a note concerningWineversion.
2023-03-13 Added a noteto showing the MD5checksum.

Addeddescriptionof UP_GetChecksumand
UP_GetChecksum_Wndv up_dll.dllfunctions.

2023-08-24 CH32V003 Fast modefunctionhas beendescribed.
2023-11-02 Addded descriptionof "Neveraskand neversave

changesto datafile"function.
2023-11-06 Addedan informationabout ProgressBar read

example.
2023-12-06 Added a notethat Linux supportwasdiscontinued.
2024-08-22 Added a new returncodeforcommandlinewhen

thedevice is protected.
2025-02-20 AddeddescriptionofAdd noteoptionfor project.
2025-03-28 Inthe ConnectingtoApplication chapteradded a

linktoachapterwhere connectors are described.
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